Bug 500732 - RFE: switch keyboard layout to USA when turning on
RFE: switch keyboard layout to USA when turning on
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
: 501920 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 16:47 EDT by Martin Sourada
Modified: 2009-09-15 02:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 02:03:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Sourada 2009-05-13 16:47:48 EDT
Description of problem:
Because most input methods seem to be designed to work best with US keyboard layout, it would be IMHO good to automatically switch to it when turing ibus on (and switch back when turing off)

Version-Release number of selected component (if applicable):
ibus-1.1.0.20090508-1.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. switch your layout to something different from USA, e.g. Cze
2. turn some ibus input method, e.g. anthy, on
  
Actual results:
keyboard layout stays same

Expected results:
kayboard layout changes to USA
Comment 1 Peng Huang 2009-06-03 01:38:41 EDT
I implemented keymap in ibus. With keymap, ibus processes scan code instead of
keysym. I think it could fix your problem. Please try the scratch build of
ibus.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1389096
Comment 2 Martin Sourada 2009-06-10 04:48:06 EDT
(In reply to comment #1)
> I implemented keymap in ibus. With keymap, ibus processes scan code instead of
> keysym. I think it could fix your problem. Please try the scratch build of
> ibus.
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1389096  
Yeah, that works almost as expected. Because the gnome keyboard layout remains same, it's kinda confusing that different layout than the one being displayed is used, but I guess one can get used to it soon.
Comment 3 Peng Huang 2009-06-15 04:57:53 EDT
*** Bug 501920 has been marked as a duplicate of this bug. ***
Comment 4 Satyabrata Maitra 2009-06-17 01:07:21 EDT
Hi Peng

Thanks for its fix! Waiting for when it will come with next release of ibus.

Note You need to log in before you can comment on or make changes to this bug.