Bug 50074 - Tix 4.1.0.6-53 compound image creation bug
Tix 4.1.0.6-53 compound image creation bug
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 11:20 EDT by Mumit Khan
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-26 11:20:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mumit Khan 2001-07-26 11:20:13 EDT
System description: RedHat 7.1, with all updates applied. Tcl/Tk versions
are:

  tcl-8.3.1-53
  tk-8.3.1-53
  tix-4.1.0.6-53
  
Description of Problem: The version of Tix distribution with RH 7.1 has
problems with creating compound images, and looks like it's a parser
bug.

How Reproducible: Very.

Steps to Reproduce:
1. Start tixwish
2. Create a compound image, specifiying a parent window.
   $ tixwish
   % image create compound -window .
   No value given for -window option.
   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ Incorrect obviously.


Actual Results: No image created due to bug. See ^^^^ above.


Expected Results: A new image, eg., image1.

Additional Information:
This is a bug in some versions of Tix 4.x, and fixed in later versions
such as Tix 8.x available from tix.sourceforge.net. Tix 8.x also fixes
other various bugs present in the older 4.x series.
Comment 1 Eido Inoue 2001-07-26 13:26:33 EDT
Try upgrading to the new 8.3.3-62 RPM in Rawhide, It uses Tix 8.x and compound
images work. (It will probably make it until the update channel, but you can get
it now from Rawhide)

Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.