Bug 500747 - no more intel KMS after kernel-2.6.29.3-140.fc11 update
no more intel KMS after kernel-2.6.29.3-140.fc11 update
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-13 17:42 EDT by Jason Farrell
Modified: 2009-08-14 10:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-17 06:50:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Farrell 2009-05-13 17:42:13 EDT
Description of problem:
After updating from kernel-2.6.29.2-126.fc11.i586 to kernel-2.6.29.3-140.fc11.i586 today, there is no more spiffy intel KMS + plymouth spinfinity during bootup. booting previous kernel, it works as expected.

Version-Release number of selected component (if applicable):
kernel-2.6.29.3-140.fc11.i586

Additional info:
Acer Aspire One netbook smolt:  http://smolts.org/show?uuid=0779b5af-ef3e-4d16-adfd-b3b646c0db38

[root@aao ~]# lspci|grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
Comment 1 Jason Farrell 2009-05-13 17:46:18 EDT
http://www.smolts.org/client/show/pub_e72ad1ae-a8ce-42b7-afac-add43026ccee
(smolt was unavailable for a bit)
Comment 2 Fabio Canepa 2009-05-14 02:39:36 EDT
Same here also on x86_64 on dell latitude d620

[fabio@f11fabio ~]$ lspci|grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 3 Fabio Canepa 2009-05-14 08:50:45 EDT
Probably has nothing to to with the latest kernel update but it's a problem with the latest plymouth update...
See https://bugzilla.redhat.com/show_bug.cgi?id=499940
Comment 4 Matthias Runge 2009-05-15 05:18:20 EDT
I can confirm this also for radeon. Seems to be some generic problem and nothing special for intel graphics.
Comment 5 Matthias Runge 2009-05-15 05:23:13 EDT
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=500897
Comment 6 Jason Farrell 2009-05-17 06:50:49 EDT
not dependent on kernel; was just an update issue with spinfinity default falling back to text.

fixed by doing:
# plymouth-set-default-theme --list
# plymouth-set-default-theme charge --rebuild-initrd
Comment 7 Matthias Runge 2009-05-18 01:58:43 EDT
Jason,
thank you for making things clear.

Note You need to log in before you can comment on or make changes to this bug.