Bug 500777 - firefox crash
firefox crash
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 04:24 EDT by Jason Haar
Modified: 2009-11-27 18:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-27 18:06:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bugreport generated by crash (576.84 KB, text/plain)
2009-05-14 04:24 EDT, Jason Haar
no flags Details

  None (edit)
Description Jason Haar 2009-05-14 04:24:03 EDT
Created attachment 343925 [details]
bugreport generated by crash

Description of problem:

My machine had been up <2 hours, last reboot was to load latest kernel from "yum update" (2.6.29.3-140.fc11.i686.PAE)

I was on a website and firefox just crashed. It generated a firefox-bugreport.txt file which I will attach

Version-Release number of selected component (if applicable):


How reproducible:

no idea

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2009-05-14 06:05:02 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Unfortunately, that backtrace you've sent is intended for the upstream system, and it doesn't work for Fedora at all. Could please provide us backtrace in the good old gdb way, please?

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jason Haar 2009-05-14 06:21:06 EDT
rpm -q

flash-plugin-10.0.22.87-release.i386
xulrunner-devel-1.9.1-0.20.beta4.fc11.i586
mozilla-filesystem-1.9-4.fc11.i586
firefox-3.5-0.20.beta4.fc11.i586
beagle-firefox-0.3.9-6.fc11.i586
xulrunner-1.9.1-0.20.beta4.fc11.i586

I went to install the debug version but it's over  225M of dependencies! That's a bit rich for my home link (volume charging) - I'll have to wait until I get back to work.

This is going to be hard to catch. I've been running FC11-preview for 3 weeks now and this is the first crash I've had of FF - so I'm not expecting it to crash any time soon

Jason
Comment 3 Bug Zapper 2009-06-09 11:48:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Chris Campbell 2009-11-27 12:56:39 EST
Jason,
Have there been any further occurrences of the crash?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Jason Haar 2009-11-27 15:56:05 EST
Nope. I've also upgraded to FC12 - which means a different version of FF too
Comment 6 Matěj Cepl 2009-11-27 18:06:35 EST
(In reply to comment #5)
> Nope. I've also upgraded to FC12 - which means a different version of FF too  

It doesn't have to ... we are keeping pretty close in different versions.

Feel free to reopen if it happens again.

Thank you for filing the bug

Note You need to log in before you can comment on or make changes to this bug.