Bug 500801 - kernel-2.6.29.3-140.fc11.x86_64 breaks Xorg on Radeon HD 3450
kernel-2.6.29.3-140.fc11.x86_64 breaks Xorg on Radeon HD 3450
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 500990 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 05:36 EDT by Wolfgang Rupprecht
Modified: 2009-05-15 21:48 EDT (History)
12 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.12.2-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 04:05:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file from failing kernel-2.6.29.3-140.fc11.x86_64 (37.81 KB, text/plain)
2009-05-14 05:36 EDT, Wolfgang Rupprecht
no flags Details
Xorg log file from good kernel kernel-2.6.29.2-126.fc11.x86_64 (74.03 KB, text/plain)
2009-05-14 05:38 EDT, Wolfgang Rupprecht
no flags Details
dmesg from failing kernel-2.6.29.3-140.fc11.x86_64 (37.36 KB, text/plain)
2009-05-14 06:43 EDT, Wolfgang Rupprecht
no flags Details
dmesg from Radeon X800 (R420) (29.80 KB, text/plain)
2009-05-14 08:54 EDT, Sebastian Vahl
no flags Details

  None (edit)
Description Wolfgang Rupprecht 2009-05-14 05:36:29 EDT
Created attachment 343931 [details]
Xorg log file from failing kernel-2.6.29.3-140.fc11.x86_64

Description of problem:

Xorg no longer starts on a Radeon HD 3450 after the latest kernel update to kernel-2.6.29.3-140.fc11.x86_64.  Reverting to the previous kernel kernel-2.6.29.2-126.fc11.x86_64 fixes things.

Version-Release number of selected component (if applicable):
kernel-2.6.29.3-140.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot
2. sit back and admire the black screen
3.
  
Actual results:
One sees a Black screen

Expected results:
One sees a spiffy gdm login window

Additional info:

Xorg prints the following just before choking:
WW) RADEON(0): DRI2: failed to open drm device
Comment 1 Wolfgang Rupprecht 2009-05-14 05:38:45 EDT
Created attachment 343932 [details]
Xorg log file from good kernel kernel-2.6.29.2-126.fc11.x86_64
Comment 2 Yanko Kaneti 2009-05-14 06:33:46 EDT
Perhaps you can login remotely and get the kernel log of the crash. (dmesg)
It sound like this HD 3650 report 
http://www.redhat.com/archives/fedora-test-list/2009-May/msg00625.html
which looks the same as this HD 3200 problem of mine
http://www.declera.com/~yaneti/2.6.29.3-142.fc11.x86_64-HD3200.log
Comment 3 Wolfgang Rupprecht 2009-05-14 06:43:18 EDT
Created attachment 343941 [details]
dmesg from failing kernel-2.6.29.3-140.fc11.x86_64
Comment 4 Remy Maucherat 2009-05-14 07:57:35 EDT
Same on RV770.
Comment 5 Sebastian Vahl 2009-05-14 08:54:50 EDT
Created attachment 343965 [details]
dmesg from Radeon X800 (R420)

This kernel is also not working for me:
01:00.0 VGA compatible controller: ATI Technologies Inc R420 JI [Radeon X800PRO]
01:00.1 Display controller: ATI Technologies Inc R420 [Radeon X800 PRO/GTO] (Secondary)
Comment 6 Kevin DeKorte 2009-05-14 09:03:07 EDT
I have an ATI 3650 card, and the kernel-2.6.29.3-140.fc11.x86_64 fails
to boot, but kernel-2.6.29.2-126.fc11.x86_64 works fine.. from
/var/log/messages I see this

So, I would pull kernel -140 or issue a new one with the fix


May 13 17:56:15 localhost kernel: Modules linked in: ipt_MASQUERADE
iptable_nat nf_nat sco bridge stp llc bnep l2cap bluetooth vfat fat
sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6
cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm
uinput snd_hda_codec_atihdmi snd_hda_codec_intelhdmi
snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_usb_audio
snd_usb_lib snd_rawmidi snd_seq_device snd_pcm snd_hwdep pwc snd_timer
videodev snd firewire_ohci usb_storage pata_jmicron i2c_i801 iTCO_wdt
iTCO_vendor_support v4l1_compat v4l2_compat_ioctl32 asus_atk0110
firewire_core crc_itu_t soundcore snd_page_alloc pcspkr atl1 serio_raw
mii hwmon joydev ata_generic pata_acpi radeon drm i2c_algo_bit i2c_core
[last unloaded: microcode]
May 13 17:56:15 localhost kernel: Pid: 2479, comm: Xorg Not tainted
2.6.29.3-140.fc11.x86_64 #1 P5E-VM HDMI
May 13 17:56:15 localhost kernel: RIP: 0010:[<ffffffff811bc752>]
[<ffffffff811bc752>] __list_add+0x3f/0x81
May 13 17:56:15 localhost kernel: RSP: 0018:ffff880125105b78  EFLAGS:
00010246
May 13 17:56:15 localhost kernel: RAX: ffff88012d1fa000 RBX:
ffff88012d1fa668 RCX: ffffffff00f7ff5f
May 13 17:56:15 localhost kernel: RDX: ffff88012d1fa668 RSI:
0000000000000000 RDI: ffff88012b55e468
May 13 17:56:15 localhost kernel: RBP: ffff880125105b98 R08:
0000000000000000 R09: 0000000000000000
May 13 17:56:15 localhost kernel: R10: 0000000000fffff0 R11:
ffffffffffffffff R12: 0000000000000000
May 13 17:56:15 localhost kernel: R13: ffff88012b55e468 R14:
ffff88012d1fa000 R15: 0000000000000000
May 13 17:56:15 localhost kernel: FS:  00007fc9927457b0(0000)
GS:ffff88012ea7b200(0000) knlGS:0000000000000000
May 13 17:56:15 localhost kernel: CS:  0010 DS: 0000 ES: 0000 CR0:
0000000080050033
May 13 17:56:15 localhost kernel: CR2: 0000000000000000 CR3:
000000012500e000 CR4: 00000000000026e0
May 13 17:56:15 localhost kernel: DR0: 0000000000000000 DR1:
0000000000000000 DR2: 0000000000000000
May 13 17:56:15 localhost kernel: DR3: 0000000000000000 DR6:
00000000ffff0ff0 DR7: 0000000000000400
May 13 17:56:15 localhost kernel: Process Xorg (pid: 2479, threadinfo
ffff880125104000, task ffff880128e15c00)
May 13 17:56:15 localhost kernel: Stack:
May 13 17:56:15 localhost kernel: 0000000000000000 ffff88012b55e400
0000000000000000 ffff88012d1fa020
May 13 17:56:15 localhost kernel: ffff880125105ba8 ffffffffa00224dd
ffff880125105bb8 ffffffffa0022517
May 13 17:56:15 localhost kernel: ffff880125105c68 ffffffffa002406d
ffff88012b55e468 000000002d167660
May 13 17:56:15 localhost kernel: Call Trace:
May 13 17:56:15 localhost kernel: [<ffffffffa00224dd>]
list_add_tail+0x15/0x17 [drm]
May 13 17:56:15 localhost kernel: [<ffffffffa0022517>]
drm_bo_add_to_lru+0x38/0x48 [drm]
May 13 17:56:15 localhost kernel: [<ffffffffa002406d>]
drm_bo_do_validate+0x48e/0x4f9 [drm]
May 13 17:56:15 localhost kernel: [<ffffffffa001ac2e>] ?
drm_mm_split_at_start+0x57/0x71 [drm]
May 13 17:56:15 localhost kernel: [<ffffffffa0024e98>]
drm_buffer_object_create+0x2e4/0x324 [drm]
May 13 17:56:15 localhost kernel: [<ffffffffa005dd2a>]
radeon_gem_object_alloc+0xcb/0x110 [radeon]
May 13 17:56:15 localhost kernel: [<ffffffffa005ddc0>]
radeon_gem_create_ioctl+0x51/0x106 [radeon]
May 13 17:56:15 localhost kernel: [<ffffffff810b4530>] ?
handle_mm_fault+0x349/0x7c5
May 13 17:56:15 localhost kernel: [<ffffffffa005dd6f>] ?
radeon_gem_create_ioctl+0x0/0x106 [radeon]
May 13 17:56:15 localhost kernel: [<ffffffffa0012b7e>]
drm_ioctl+0x20e/0x2c5 [drm]
May 13 17:56:15 localhost kernel: [<ffffffff8105fd6e>] ? up_read+0xe/0x10
May 13 17:56:15 localhost kernel: [<ffffffff813ae09b>] ?
do_page_fault+0x5fb/0x9e9
May 13 17:56:15 localhost kernel: [<ffffffff810e0e94>] vfs_ioctl+0x6f/0x87
May 13 17:56:15 localhost kernel: [<ffffffff810e132f>]
do_vfs_ioctl+0x462/0x4a3
May 13 17:56:15 localhost kernel: [<ffffffff810d4c17>] ?
fsnotify_modify+0x64/0x6c
May 13 17:56:15 localhost kernel: [<ffffffff813ab4ed>] ?
trace_hardirqs_off_thunk+0x3a/0x6c
May 13 17:56:15 localhost kernel: [<ffffffff810e13c6>] sys_ioctl+0x56/0x79
May 13 17:56:15 localhost kernel: [<ffffffff8101133a>]
system_call_fastpath+0x16/0x1b
May 13 17:56:15 localhost kernel: Code: ec 08 4c 8b 42 08 49 39 f0 74 20
49 89 d1 48 89 f1 48 c7 c2 27 02 4f 81 be 1a 00 00 00 48 c7 c7 dc 01 4f
81 31 c0 e8 b1 c1 e8 ff <4d> 8b 04 24 49 39 d8 74 20 4d 89 e1 48 89 d9
48 c7 c2 74 02 4f
May 13 17:56:15 localhost kernel: RIP  [<ffffffff811bc752>]
__list_add+0x3f/0x81
May 13 17:56:15 localhost kernel: RSP <ffff880125105b78>
May 13 17:56:15 localhost kernel: CR2: 0000000000000000
May 13 17:56:15 localhost kernel: ---[ end trace c4d7f17535517d7d ]---
Comment 7 Sebastian Vahl 2009-05-14 09:04:35 EDT
(In reply to comment #5)
> Created an attachment (id=343965) [details]
> dmesg from Radeon X800 (R420)
> 
> This kernel is also not working for me:
> 01:00.0 VGA compatible controller: ATI Technologies Inc R420 JI [Radeon
> X800PRO]
> 01:00.1 Display controller: ATI Technologies Inc R420 [Radeon X800 PRO/GTO]
> (Secondary)  

I have to add that I normally use "nomodeset" (also for this dmesg output). Without nomodeset X is starting here.
Comment 8 Jon Escombe 2009-05-14 09:16:55 EDT
Same issue here with nomodeset and an ATI Mobility Radeon X1400 (Lenovo T60).
Comment 9 Michal Jaegermann 2009-05-14 13:52:12 EDT
The same crash shows up also with an "older" Radeon card (ATI Technologies Inc R300 AD [Radeon 9500 Pro]). Just
BUG: unable to handle kernel NULL pointer dereference at (null)
IP: [<ffffffff811bc752>] __list_add+0x3f/0x81
with a call trace like in comment #6.
Comment 10 Kyle McMartin 2009-05-15 00:07:01 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=1355579

Please try this xorg-x11-drv-ati update, fixes the issue on my r700.

23:38  kyle$ well, the -ati X driver assumes drm driver minor version >= 30 implies GEM/TTM.
23:38  kyle$ and this commit to the radeon drm driver cranks it to 30
23:38  kyle$ http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=commitdiff;h=e8a1344119f3787b822d110336e5dd33f6ffca70
23:39  kyle$ presumably this enabling GEM/TTM is unintentional.
Comment 11 Wolfgang Rupprecht 2009-05-15 00:17:35 EDT
xorg-x11-drv-ati.x86_64 0:6.12.2-14.fc11 fixed the problem for me.
Comment 12 Jon Escombe 2009-05-15 03:05:35 EDT
Can onfirm xorg-x11-drv-ati-6.12.2-14 fixes the problem for me as well, thanks.
Comment 13 Jeff Layton 2009-05-15 21:48:00 EDT
*** Bug 500990 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.