Bug 500865 - [RHEL5 U4] Xen HVM NFS connectathon tests are running 10X slower
[RHEL5 U4] Xen HVM NFS connectathon tests are running 10X slower
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
medium Severity high
: rc
: 5.5
Assigned To: Xen Maintainance List
Red Hat Kernel QE team
http://rhts.redhat.com/cgi-bin/rhts/t...
:
Depends On:
Blocks: 533192
  Show dependency treegraph
 
Reported: 2009-05-14 11:28 EDT by Jeff Burke
Modified: 2009-11-05 10:14 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 10:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xml for rhts (4.12 KB, text/plain)
2009-05-14 11:29 EDT, Jeff Burke
no flags Details

  None (edit)
Description Jeff Burke 2009-05-14 11:28:36 EDT
Description of problem:
 We have been seeing a slow down in NFS traffic while running the with the RHEL5.4 kernels on a fully virtulized xen guest.

Version-Release number of selected component (if applicable):
2.6.18-147.el5

How reproducible:
Very often

Steps to Reproduce:
1. I attached an RHTS xml that duplicates the issue
  
Actual results:
Connectathon tests use to average 8 min. Currently they are average 47 min. 

Expected results:
Should run much faster

Additional info:
Comment 1 Jeff Burke 2009-05-14 11:29:38 EDT
Created attachment 343992 [details]
xml for rhts
Comment 2 Chris Lalancette 2009-05-19 07:42:56 EDT
OK, I was able to reproduce (once) on nec-em19.rhts.bos.redhat.com.  With the -148 kernel on the dom0, and the -148 kernel in the HVM guest, I ran just a test against the rhel5-nfs server.  That test ended up taking 4003 seconds.  I then ran the same test with a -148 dom0 kernel and a -135 kernel in the HVM guest, and the test took 3832 seconds.  So, not much difference there, and that seems to point the finger at the dom0.

However, after rebooting the dom0, I am wholly unable to reproduce the problem.  I rebooted the dom0 into the -148 kernel, and ran the same tests, and came up with numbers like 400 seconds, which is around what they should be.  So something about how rhts sets up the initial tests gets it into this bad state, and it's bad from then on.  At this point, I might have to re-submit the RHTS job to prove what's going on.

Chris Lalancette
Comment 5 Justin M. Forbes 2009-05-28 01:59:11 EDT
It seems that this can only be reproduced as a part of the full set of rhts tests.  I have tried several times to reproduce with just the connectathon test and have not been successful.
Comment 20 Bill Burns 2009-10-13 14:07:45 EDT
Jeff, ok to close this as in the end it was bad hardware, right?

Note You need to log in before you can comment on or make changes to this bug.