Bug 500912 - Downloading Packages messages are truncated on serial console, due to termwidth == 0
Downloading Packages messages are truncated on serial console, due to termwid...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-urlgrabber (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
Petr Šplíchal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 16:34 EDT by Nate Straz
Modified: 2016-05-31 21:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: python-urlgrabber-3.1.0-6.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 17:12:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2009-05-14 16:34:04 EDT
Description of problem:

When yum downloads packages and prints out progress messages, the lines are truncated so they don't show what is being downloaded.

================================================================================
 Package              Arch            Version              Repository      Size
================================================================================
Installing:
 sts-rhel5.4          x86_64          1-1.el5              mspqa          621 k
Installing for dependencies:
 collie               x86_64          0.14-1.el5           mspqa           40 k
 gxpp                 x86_64          1.0-1.el5            mspqa           12 k

Transaction Summary
================================================================================
Install      3 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 673 k
Is this ok [y/N]: y
Downloading Packages:
(1/3): g
(2/3): c
(3/3): s
--------
Total
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : collie                                                   1/3
  Installing     : gxpp                                                     2/3
  Installing     : sts-rhel5.4                                              3/3

Installed:
  sts-rhel5.4.x86_64 0:1-1.el5

Dependency Installed:
  collie.x86_64 0:0.14-1.el5               gxpp.x86_64 0:1.0-1.el5

Complete!


Version-Release number of selected component (if applicable):
yum-3.2.22-10.el5

How reproducible:
Every time

Steps to Reproduce:
1. yum install anything
  
Actual results:
download messages are incomplete

Expected results:
The complete package name should be printed while packages are being downloaded.

Additional info:
Comment 1 James Antill 2009-05-14 16:46:56 EDT
I can't reproduce this ... can I have access to the box this is happening on?
Are you doing anything "weird", like pipe output to expect?
Comment 2 James Antill 2009-05-18 11:43:19 EDT
Nate, ping?
Comment 3 Nate Straz 2009-05-18 11:55:46 EDT
Sorry, I must have missed your earlier add.

This appears to be a problem when I run yum via the serial console.  I just tried it over a serial console and via ssh.  The serial console still truncated the output, but the ssh session looked correct.
Comment 4 James Antill 2009-05-18 12:17:29 EDT
Ahh, right ... yeh, this is a urlgrabber "bug" in that we call fcntl.ioctl(fd, termios.TIOCGWINSZ, buf) ... and it reutrns 0.
 yum itself works around this by doing 0 == 80, which should probably be moved down into urlgrabber itself.

 I'll propose for 5.5
Comment 5 RHEL Product and Program Management 2009-11-06 14:05:50 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 James Antill 2010-07-02 13:00:25 EDT
urlgrabber is on the 5.6 list, so we should fix this too.
Comment 11 errata-xmlrpc 2011-01-13 17:12:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0038.html

Note You need to log in before you can comment on or make changes to this bug.