Bug 500913 - AttributeError: 'SwapSpace' object has no attribute 'mountpoint'
AttributeError: 'SwapSpace' object has no attribute 'mountpoint'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 501052 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 16:35 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 17:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ks.cfg (4.57 KB, text/plain)
2009-05-14 16:35 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-05-14 16:35:25 EDT
Created attachment 344045 [details]
ks.cfg

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Perform kickstart install using autopart defaults
2. Perform kickstart install using manual LVM disk setup (see attachment)
  
Actual results:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 932, in <module>
    kickstart.fullCommandPass(anaconda, opts.ksfile, earlyKS)
  File "/usr/lib/anaconda/kickstart.py", line 1197, in fullCommandPass
    ksparser.readKickstart(file)
  File "/usr/lib/python2.6/site-packages/pykickstart/parser.py", line 759, in readKickstart
    <Tab>/<Alt-Tab> between elements   |  <Space> select    self._stateMachine (lambda: fh.readline())
  File "/usr/lib/python2.6/site-packages/pykickstart/parser.py", line 634, in _stateMachine
    self.handleCommand(lineno, args)
  File "/usr/lib/anaconda/kickstart.py", line 1121, in handleCommand
    KickstartParser.handleCommand(self, lineno, args)
  File "/usr/lib/python2.6/site-packages/pykickstart/parser.py", line 467, in handleCommand
    self.handler.dispatcher(args, lineno, self._preceededInclude)
  File "/usr/lib/python2.6/site-packages/pykickstart/base.py", line 376, in dispatcher
    obj = self.commands[cmd].parse(args[1:])
  File "/usr/lib/anaconda/kickstart.py", line 430, in parse
    if format.mountpoint:

AttributeError: 'SwapSpace' object has no attribute 'mountpoint'
install exited abnormally [1/1] 
disabling swap...
unmounting filesystems...
/mnt/runtime done
disabling /dev/loop0 LOOP_CLR_FD failed: 16
/proc done
/dev/pts done
/sys done
/selinux done
sending termination signals...done
sending kill signals...done
you may safely reboot your system


Expected results:

Successful install

Additional info:

 * See attached kickstart
Comment 1 Chris Lumens 2009-05-14 17:14:27 EDT
This will be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 2 Chris Lumens 2009-05-15 14:27:21 EDT
*** Bug 501052 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.