Bug 50093 - Elm update crashes on out of disk space
Elm update crashes on out of disk space
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: elm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 15:10 EDT by Alan Cox
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-30 21:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2001-07-26 15:10:10 EDT
bash-2.04$ elm
Close failed on temp file "/home/anarchy/.elm/mbox.alan.alan"! [No space
left on device]
Discarding any changes made to mail folder ...
Received Segment Violation signal!
Emergency exit taken!
bash-2.04$ df .
Comment 1 Trond Eivind Glomsrxd 2001-07-30 19:04:15 EDT
Can you check if elm-2.5.5-5 fixes the segmantation fault?
Comment 2 Michael Schwendt 2001-07-30 21:38:11 EDT
$ rpm -q elm
elm-2.5.5-5

$ elm
Write failed in copy_message()! [No space left on device]
Emergency exit taken!
Preserving editor composition file "/home/ms/.elm/tmp/snd.21715" ...
Preserving temporary folder "/home/ms/.elm/mbox.ms.ms" ...

Comment 3 Michael Schwendt 2001-07-30 21:42:56 EDT
Steps to reproduce: 

1. export TMPDIR=/some/dir on a partition to be filled up
2. start "elm"
3. fill partition that holds /some/dir, so "df" prints "0"
4. delete a message (marks it a D) and quit
Comment 4 Michael Schwendt 2001-07-30 21:45:02 EDT
Means, SegFault not reproducible at my end. Most likely not an out-of-disk-space
problem.
Comment 5 Trond Eivind Glomsrxd 2001-07-31 00:28:31 EDT
Ok, elm-2.5.5-5 fixes the problem then. Creating more diskspace is a little out
of scope.

Comment 6 Michael Schwendt 2001-07-31 08:15:25 EDT
Though, if there hasn't been a specific fix for anything like this in 2.5.5-5,
this one should be kept an eye on. Alan's case looks like there could be more
involved than just out-of-disk-space.

Note You need to log in before you can comment on or make changes to this bug.