Bug 500937 - Error message is too vague when apply for a certificate with a missing UID.
Error message is too vague when apply for a certificate with a missing UID.
Status: CLOSED WONTFIX
Product: Dogtag Certificate System
Classification: Community
Component: Profile (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Christina Fu
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-14 20:24 EDT by Asha Akkiangady
Modified: 2015-01-04 18:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-15 14:46:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Asha Akkiangady 2009-05-14 20:24:44 EDT
Description of problem:
Error message is too vague when certificate is requested with profile "Manual User Dual-Use Certificate Enrollment" with a missing UID value.

Version-Release number of selected component (if applicable):
CS 8.0


How reproducible:


Steps to Reproduce:
1.From the CA ee page select profile "Manual User Dual-Use Certificate Enrollment" to apply for a cert.

2. Fill in all the values except UID and click submit.
  
Actual results:
Error message displayed is:
Sorry, your request has been rejected. The reason is "Request Rejected - Subject Name Not Matched E=profiletest18@redhat.com,CN=profiletest18,OU=redhat3,OU=redhat2,OU=redhat1,OU=redhat,O=redhat,C=USA"

Expected results:
Helpful error message should be displayed.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.