Bug 500988 - Initial errors running ocs-setup
Initial errors running ocs-setup
Status: CLOSED ERRATA
Product: Red Hat HPC Solution
Classification: Red Hat
Component: ocs (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: OCS Support
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 07:49 EDT by javier
Modified: 2015-01-07 19:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 17:01:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/kusu/kusu-kitops (461 bytes, text/plain)
2009-05-18 12:55 EDT, javier
no flags Details

  None (edit)
Description javier 2009-05-15 07:49:51 EDT
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SV1; SLCC1; .NET CLR 2.0.50727; .NET CLR 1.1.4322; InfoPath.2; .NET CLR 3.5.30729; .NET CLR 3.0.30618)

Hello,

I have a problem installing RHEL HPC Solution.
ocs-setup program displays errors adding OS media 





Please any idea ?

Reproducible: Always

Steps to Reproduce:
1.Install RHEL 5.3 Server x86_64, register, yum update, assign to HPC Solution channel.
2.yum install ocs mod_ssl and (update all)
3.Run ocs-setup  (ocs-5.3.4)

Actual Results:  
..

The Os media is needed at this time.Do yo have Os media on Disks,Iso,or Filesystem ? (Disk|Iso|File) [Disk] Iso
enter the fully qualified path to the ISO file, or the directory containing the files:
/dats/rhel-server-5.3-x86_64-dvd.iso  
Copyng the media. Please wait this will take some time!
Traceback (most recentcall last):
File "/opt/Kusu/bin/kitops",line 655,in ?
app.run ()
File "/opt/Kusu/bin/kitops",line 224,in run
Self.runAdd()
File "/opt/Kusu/bin/kitops",line 275,in runAdd
Self.logEvent(self._("kitops_event_add_kits_from_media") % Koinst.kitmedia,
TypeError:not all arguments converted during string formatting.

...


prove with media: ISO,Files and disk
Comment 1 javier 2009-05-18 12:55:24 EDT
Created attachment 344482 [details]
/var/log/kusu/kusu-kitops
Comment 2 OCS Support 2009-05-19 12:30:46 EDT
Hi,
Did you run the steps in this order
1.Install RHEL 5.3 Server x86_64, register, yum update, assign to HPC Solution
channel.
2.yum install ocs mod_ssl and (update all)
3. source /etc/profile.d/kusuenv.sh
4.Run ocs-setup  (ocs-5.3.4)

Step 3 is important, can you confirm if it was run?
Ref: http://www.redhat.com/docs/en-US/hpc/1.0/html/sect-Installation_Guide-Installation_Procedure-Starting_the_Install.html
Comment 3 javier 2009-05-19 17:34:13 EDT
(In reply to comment #2)
> Hi,
> Did you run the steps in this order
> 1.Install RHEL 5.3 Server x86_64, register, yum update, assign to HPC Solution
> channel.
> 2.yum install ocs mod_ssl and (update all)
> 3. source /etc/profile.d/kusuenv.sh
> 4.Run ocs-setup  (ocs-5.3.4)
> Step 3 is important, can you confirm if it was run?
> Ref:
> http://www.redhat.com/docs/en-US/hpc/1.0/html/sect-Installation_Guide-Installation_Procedure-Starting_the_Install.html  

Of course. I forgot to indicate
Comment 4 OCS Support 2009-05-20 00:30:38 EDT
Hi Javier, 
What is the language setting on the system?
 Is  it possible for you to retry with the setting set to en_US which is the default if its not? 
I think the issue may be because self._("kitops_event_add_kits_from_media") % Koinst.kitmedia tries to translate the error message to the language set by the OS. The translation is not available and therefore it returns just "kitops_event_add_kits_from_media", causing the error.
Comment 5 javier 2009-05-20 11:15:32 EDT
language and keyboard is spanish.

If run ocs-setup detect false settings :
language=en
Keyboard =us

If change the general settings for session to language en-USA, then continues to run !! (this is a bug?)
./ocs-setup

Fully-qualified Hostname = MACHINE.DOMAIN.
Short Hostname           = MACHINE
Timezone                 = Europe/Madrid
UTC time                 = 1
Gateway                  = 
DNS servers              = ['127.0.0.1']
DNS Search order         = ocs5 XXXX
Language                 = en
Keyboard                 = us

Detected network interfaces:

ETH0
ETH1
ETH3
...

It is not recommended to provision on a public network interface as it
may be disruptive to regular network operation.

The following interfaces are available for provisioning: eth2 eth0

Do you wish to provision on all interfaces [N/y]? N

Specify interfaces to provision on (separated by spaces) [eth2]: eth0

OCS creates a DNS domain for all nodes it installs.  This node will function as a primary DNS server for this domain.

Enter the private DNS domain to create [default: ocs5]: 

OCS requires a depot directory to store kits, images and other files
A minimum of 10Gbytes is needed.

Would you like to use the default /depot directory [N/y]? y
Stopping postgresql service:                               [  OK  ]
Iniciando servicios postgresql:                            [  OK  ]
Setting permissions


The OS media is needed at this time.  Do you have OS media on
Disks, ISO, or Filesystem? (Disk|Iso|File) [Disk] 
Insert the OS media into the drive and press Enter to continue

Copying the media.  Please wait this will take some time!
Traceback (most recent call last):
  File "/opt/kusu/bin/kitops", line 655, in ?
    app.run()
  File "/opt/kusu/bin/kitops", line 224, in run
    self.runAdd()
  File "/opt/kusu/bin/kitops", line 298, in runAdd
    self.runAddOSKit(kits)
  File "/opt/kusu/bin/kitops", line 336, in runAddOSKit
    kit = self.koinst.prepareOSKit(osdistro)
  File "/opt/kusu/lib/python/kusu/kitops/kitops.py", line 486, in prepareOSKit
    kit['name'] = osdistro.ostype.lower() + osdistro.getVersionString()
  File "/opt/kusu/lib/python/kusu/boot/distro.py", line 1386, in getVersionString
    r = RPM(str(self.getReleasePkg()))
  File "/opt/kusu/lib/python/kusu/util/rpmtool.py", line 117, in __init__
    raise InvalidRPMHeader, r
kusu.util.errors.InvalidRPMHeader: /tmp/kitopspglRJ0/Server/redhat-release-5Server-5.3.0.3.x86_64.rpm


(change the media for other ISO...¿?)

Do you wish to retry this operation [N/y]?  y
Do you wish to retry this operation [N/y]?  y
The OS media is needed at this time.  Do you have OS media on
Disks, ISO, or Filesystem? (Disk|Iso|File) [Disk] Iso

Enter the fully qualified path to the ISO file, or the directory containing the files:
/dats/rhel-server-5.3-x86_64-dvd.iso
Copying the media.  Please wait this will take some time!
Any more disks for this OS kit? [y/n] 
n
Please insert next disk if installing from phys. media NOW
(URI for next ISO | blank if phys. media | N to finish): 
N
Added kit: rhel5.3-5-x86_64
Installing OCS base kit downloader
Loaded plugins: rhnplugin, security

RUNNING!!


aditional question

for re-run oc-setup is oc-setup -U ??
Comment 7 Jay Turner 2009-06-16 08:12:38 EDT
Fix confirmed with kusu-core-5.2-4 using es_ES.UTF-8 and de_DE.UTF-8.
Comment 9 errata-xmlrpc 2009-06-17 17:01:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1115.html

Note You need to log in before you can comment on or make changes to this bug.