Bug 501001 - Firmware update fails on HP 1x8 Autoloader tape device using LSI Logic / Symbios Logic 53c1030
Firmware update fails on HP 1x8 Autoloader tape device using LSI Logic / Sym...
Status: CLOSED DUPLICATE of bug 500984
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
i686 Linux
low Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 09:04 EDT by Senthil Kumar V
Modified: 2009-05-20 11:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 500984
Environment:
Last Closed: 2009-05-20 11:22:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Senthil Kumar V 2009-05-15 09:04:40 EDT
On RedHat EL 5 update 2, firmware update on a "HP StorageWorks 1x8 Autoloader"
(with Ultrium-3 tape drive) fails.
The SCSI HBA to which the Autoloader is connected to, is a LSI Logic / Symbios
Logic 53c1030

Tried 2 driver versions of LSI HBA. versions mptlinux-3.12.29.00rh and
4.00.43.00
It fails consistently.

But if the autoloader has a Ultrium-2 tape drive (instead of Ultrium-3) the
firmware upgrade is successful.

For firmware upgrade on the 1x8 auto loader, we used "HP StorageWorks Library
and Tape Tools" which is a free download from HP website.
(www.hp.com/support/tapetools).



Reproducible: Always

Steps to Reproduce:
1.Connect HP Storageworks 1x8 Autoloader with LTO-3 drive
2.Start HP Library and Tape Tools (L&TT) and download firmware for the
autoloader from HP website.

3.upgrade/downgrade firmware using L&TT, to the 1x8 Autoloader (not the LTO
drive)

4. at the end of the upgrade process, L&TT will report failure.
5. Observe the /var/log/messages file to see the logs.
Actual Results:  
The SCSI subsystem (or driver) of RH EL 5 drops the last portion of the
firmware file thus the device was not able to upgrade the firmware. This happen
only for the 1x8 Autoloader with LTO-3 drive. It works for a 1x8 Autoloader
with LTO-2 or LTO-1 drive.

(Please see the attached messages from /var/log/messages)

Expected Results:  
L&TT should upgrade the firmware on the 1x8 Autoloader.

Given below is the logs for /var/log/messages
==================================================================================


May 15 11:21:39 katrina-ltt smartd[5490]: smartd has fork()ed into background
mode. New PID=5490.
May 15 11:31:16 katrina-ltt kernel: mptscsih: ioc0: attempting task abort!
(sc=c23b9200)
May 15 11:31:16 katrina-ltt kernel: scsi 0:0:4:1:
May 15 11:31:16 katrina-ltt kernel:         command: Write Buffer: 3b 04 00 04
00 00 00 59 7d 00
May 15 11:31:26 katrina-ltt kernel: mptscsih: ioc0: WARNING - Issuing Reset
from mptscsih_IssueTaskMgmt!!
May 15 11:31:27 katrina-ltt kernel: mptscsih: ioc0: task abort: SUCCESS
(sc=c23b9200)
May 15 11:31:27 katrina-ltt kernel:  target0:0:4: Beginning Domain Validation
May 15 11:31:27 katrina-ltt kernel:  target0:0:4: Domain Validation skipping
write tests
May 15 11:31:27 katrina-ltt kernel:  target0:0:4: Ending Domain Validation
May 15 11:31:27 katrina-ltt kernel:  target0:0:4: FAST-160 WIDE SCSI 320.0 MB/s
DT IU RTI PCOMP (6.25 ns, offset 64)
May 15 11:31:27 katrina-ltt kernel:  target0:0:4: Beginning Domain Validation
May 15 11:31:32 katrina-ltt kernel:  target0:0:4: Ending Domain Validation
May 15 11:31:32 katrina-ltt kernel:  target0:0:4: FAST-160 WIDE SCSI 320.0 MB/s
DT IU RTI PCOMP (6.25 ns, offset 64)
Comment 1 Prarit Bhargava 2009-05-20 11:22:42 EDT

*** This bug has been marked as a duplicate of bug 500984 ***

Note You need to log in before you can comment on or make changes to this bug.