Bug 501009 - enable-debug flag breaks build
enable-debug flag breaks build
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
http://lists.freedesktop.org/archives...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 09:56 EDT by ritz
Modified: 2012-04-17 15:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 15:40:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ritz 2009-05-15 09:56:02 EDT
Description of problem:
Enabling "--enable-debug" flag breaks build

Version-Release number of selected component (if applicable):
rhel5

How reproducible:
always

Steps to Reproduce:
1. Add "--enable-debug" to configure option 
  
Actual results:
xf86Debug.c:48: warning: no previous prototype for 'xf86Break1'
xf86Debug.c:52: warning: no previous prototype for 'xf86Break2'
xf86Debug.c:56: warning: no previous prototype for 'xf86Break3'
xf86Debug.c:129: warning: no previous prototype for 'xf86PeekFb8'
xf86Debug.c:130: warning: no previous prototype for 'xf86PeekFb16'
xf86Debug.c:131: warning: no previous prototype for 'xf86PeekFb32'


Expected results:
should build

Additional info:
replace BUILDDEBUG with DEBUG .

refrence : http://lists.freedesktop.org/archives/xorg/2007-March/022423.html
Comment 1 Adam Jackson 2012-04-17 15:40:07 EDT
Don't care.

Note You need to log in before you can comment on or make changes to this bug.