Bug 501039 - thunderbird-lightning needs a proper Requires for thunderbird version
thunderbird-lightning needs a proper Requires for thunderbird version
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sunbird (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 11:39 EDT by Orion Poplawski
Modified: 2009-05-15 12:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 12:08:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-05-15 11:39:28 EDT
Description of problem:

thunderbird 3.0 was put in F-10 updates-testing, which broke the thunderbird-lightning 0.9 plugin.  I think we need:

Requires: thunderbird <= 2.<some version>

as appropriate in the package to avoid this.

Version-Release number of selected component (if applicable):
thunderbird-lightning-0.9-3.fc10.i386
Comment 1 Lubomir Rintel 2009-05-15 11:49:14 EDT
fixed in devel
Comment 2 Orion Poplawski 2009-05-15 11:59:22 EDT
I think you misunderstood.  I think we need a requires that will prevent the installation of an incompatible version of thunderbird. 

In /usr/lib/thunderbird-lightning/install.rdf there is:

    <em:targetApplication>
      <Description>
        <!-- thunderbird -->
        <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
        <em:minVersion>2.0</em:minVersion>
        <em:maxVersion>2.0.0.*</em:maxVersion>
      </Description>
    </em:targetApplication>

So I think:

Requires: thunderbird < 2.0.1

would be appropriate in addition to:

Requires: thunderbird >= 2.0
Comment 3 Lubomir Rintel 2009-05-15 12:08:05 EDT
umm, no.

I'm not going to change this for F-10 and for rawhide I can't tell how will the mozilla's internal version number change upon release compared to RPM's one therefore I can't decide about maximum RPM version number.

Note You need to log in before you can comment on or make changes to this bug.