Red Hat Bugzilla – Bug 501039
thunderbird-lightning needs a proper Requires for thunderbird version
Last modified: 2009-05-15 12:08:05 EDT
Description of problem:
thunderbird 3.0 was put in F-10 updates-testing, which broke the thunderbird-lightning 0.9 plugin. I think we need:
Requires: thunderbird <= 2.<some version>
as appropriate in the package to avoid this.
Version-Release number of selected component (if applicable):
fixed in devel
I think you misunderstood. I think we need a requires that will prevent the installation of an incompatible version of thunderbird.
In /usr/lib/thunderbird-lightning/install.rdf there is:
<!-- thunderbird -->
So I think:
Requires: thunderbird < 2.0.1
would be appropriate in addition to:
Requires: thunderbird >= 2.0
I'm not going to change this for F-10 and for rawhide I can't tell how will the mozilla's internal version number change upon release compared to RPM's one therefore I can't decide about maximum RPM version number.