Bug 501066 - Provisioning a Xen PV guest fails due to a Koan 'invalid location' error
Provisioning a Xen PV guest fails due to a Koan 'invalid location' error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
530
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Steve Salevan
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-05-15 15:24 EDT by Steve Salevan
Modified: 2009-09-10 15:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:25:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-05-15 15:24:38 EDT
Description of problem:
If a user attempts to provision a virtualized guest via the WebUI, they'll receive an rhn_check traceback related to Koan which looks something like this:

D: Sending back response (1, 'Virtual kickstart failed. Koan error.', {'koan': 'invalid location: /var/lib/xen/<name_of_guest>'})

Full traceback attached to comment #1.

Version-Release number of selected component (if applicable):
Satellite 530, 5/7 ISO

How reproducible:
Always

Steps to Reproduce:
1. Provision a virtualized guest via the SDC in the Satellite WebUI
2. Run rhn_check -vvvvv
  
Actual results:
Similar to attached rhn_check traceback

Expected results:
Xen PV guest provisioning succeeds

Additional info:
Comment 2 Justin Sherrill 2009-05-19 18:36:24 EDT
The cause of this was that the specified location already exists.  This should be handled better by the next version of spacewalk koan based on partha's update in bug 497424.
Comment 3 Steve Salevan 2009-06-03 14:21:45 EDT
VERIFIED on 5/29 build.
Comment 4 Brandon Perkins 2009-09-10 15:25:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.