Bug 501097 - BUG: unable to handle kernel NULL pointer dereference at (null)
BUG: unable to handle kernel NULL pointer dereference at (null)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-16 02:14 EDT by Maarten
Modified: 2009-06-03 05:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 05:01:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maarten 2009-05-16 02:14:28 EDT
Description of problem:
Kernel crash just after boot completes.

Version-Release number of selected component (if applicable):
kernel-2.6.29.3/140.fc1(i568)

How reproducible:
Boot the box

Steps to Reproduce:
1. Press power button
2. Wait
3.
  
Actual results:
The blue bar at the bottom of the screen completes the boot process. When X starts (assumption) nothing happens. Black screen. Next time i log in and select an older version the box boots fine. I get a notification message to send kernel crash information. 

Expected results:
A box that boots.

Additional info:

When booting with the previous kernel version I get this from a kernel crash report message. 

Kernel failure message 1:
BUG: unable to handle kernel NULL pointer dereference at (null)
IP: [<c0562bb2>] __list_add+0x2a/0x5c
*pde = 7faff067 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/enable
Modules linked in: bridge stp llc bnep sco l2cap bluetooth sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq dm_multipath uinput snd_hda_codec_atihdmi snd_hda_codec_via snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer snd soundcore iTCO_wdt usblp pcspkr i2c_i801 r8169 snd_page_alloc iTCO_vendor_support mii asus_atk0110 hwmon ata_generic pata_acpi pata_marvell radeon drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
May 16 07:36:08 localhost kernel: Pid: 1723, comm: Xorg Not tainted (2.6.29.3-140.fc11.i586 #1) System Product Name
EIP: 0060:[<c0562bb2>] EFLAGS: 00213246 CPU: 0
EIP is at __list_add+0x2a/0x5c
EAX: 00000000 EBX: f4e14c44 ECX: f5ff0c2c EDX: 00000000
ESI: 00000000 EDI: f5ff0c2c EBP: f28d7d40 ESP: f28d7d34
DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process Xorg (pid: 1723, ti=f28d6000 task=f28e0000 task.ti=f28d6000)
Stack:
00000000 f4e14c44 00000000 f28d7d48 f7caad86 f28d7d54 f7caadb9 00000000
f28d7db4 f7cac5cc 00000000 f28d7d8c c053f986 00000000 00000000 00000000
00000004 f4e14c6c f4e14c78 f5ff0800 f5ff0814 f4e14c00 f5f01400 f3f76f80
Call Trace:
[<f7caad86>] ? list_add_tail+0x12/0x14 [drm]
[<f7caadb9>] ? drm_bo_add_to_lru+0x31/0x3f [drm]
[<f7cac5cc>] ? drm_bo_do_validate+0x466/0x4c2 [drm]
[<c053f986>] ? security_transition_sid+0x15/0x17
[<f7cad1d3>] ? drm_buffer_object_create+0x29d/0x2ce [drm]
[<f7d60f16>] ? radeon_gem_object_alloc+0xb1/0xea [radeon]
[<f7d60f9c>] ? radeon_gem_create_ioctl+0x4d/0xec [radeon]
[<c055fd01>] ? copy_from_user+0x32/0x119
[<f7c9d602>] ? drm_ioctl+0x202/0x296 [drm]
[<f7d60f4f>] ? radeon_gem_create_ioctl+0x0/0xec [radeon]
[<c0532c7b>] ? inode_has_perm+0x60/0x6a
[<c04aaa58>] ? vfs_ioctl+0x5a/0x74
[<c04ab254>] ? do_vfs_ioctl+0x480/0x4ba
[<c0533031>] ? selinux_file_ioctl+0x3f/0x42
[<c04ab2d4>] ? sys_ioctl+0x46/0x66
[<c0403f72>] ? syscall_call+0x7/0xb
Code: c3 55 89 e5 57 89 cf 56 89 d6 53 89 c3 8b 41 04 39 d0 74 17 51 50 52 68 be 13 80 c0 6a 1a 68 73 13 80 c0 e8 c7 c6 ec ff 83 c4 18 <8b> 06 39 f8 74 17 56 50 57 68 0b 14 80 c0 6a 1e 68 73 13 80 c0 
EIP: [<c0562bb2>] __list_add+0x2a/0x5c SS:ESP 0068:f28d7d34
---[ end trace 647464b16f7453ef ]---


Kernel failure message 2:
BUG: unable to handle kernel NULL pointer dereference at (null)
IP: [<c0562bb2>] __list_add+0x2a/0x5c
*pde = 7f8ee067 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/enable
Modules linked in: bridge stp llc bnep sco l2cap bluetooth sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq dm_multipath uinput snd_hda_codec_atihdmi snd_hda_codec_via snd_hda_intel snd_hda_codec snd_hwdep snd_pcm i2c_i801 snd_timer asus_atk0110 hwmon iTCO_wdt iTCO_vendor_support snd soundcore snd_page_alloc r8169 mii pcspkr ata_generic pata_acpi pata_marvell radeon drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
May 15 18:17:35 localhost kernel: Pid: 1691, comm: Xorg Not tainted (2.6.29.3-140.fc11.i586 #1) System Product Name
EIP: 0060:[<c0562bb2>] EFLAGS: 00213246 CPU: 1
EIP is at __list_add+0x2a/0x5c
EAX: 00000000 EBX: f593e344 ECX: f5ff0c2c EDX: 00000000
ESI: 00000000 EDI: f5ff0c2c EBP: f24c7d40 ESP: f24c7d34
DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Process Xorg (pid: 1691, ti=f24c6000 task=f24825e0 task.ti=f24c6000)
Stack:
00000000 f593e344 00000000 f24c7d48 f7caad86 f24c7d54 f7caadb9 00000000
f24c7db4 f7cac5cc 00000000 f24c7d8c c053f986 00000000 00000000 00000000
00000004 f593e36c f593e378 f5ff0800 f5ff0814 f593e300 f5f01500 f33e32c0
Call Trace:
[<f7caad86>] ? list_add_tail+0x12/0x14 [drm]
[<f7caadb9>] ? drm_bo_add_to_lru+0x31/0x3f [drm]
[<f7cac5cc>] ? drm_bo_do_validate+0x466/0x4c2 [drm]
[<c053f986>] ? security_transition_sid+0x15/0x17
[<f7cad1d3>] ? drm_buffer_object_create+0x29d/0x2ce [drm]
[<f7d60f16>] ? radeon_gem_object_alloc+0xb1/0xea [radeon]
[<f7d60f9c>] ? radeon_gem_create_ioctl+0x4d/0xec [radeon]
[<c055fd01>] ? copy_from_user+0x32/0x119
[<f7c9d602>] ? drm_ioctl+0x202/0x296 [drm]
[<f7d60f4f>] ? radeon_gem_create_ioctl+0x0/0xec [radeon]
[<c0532c7b>] ? inode_has_perm+0x60/0x6a
[<c04aaa58>] ? vfs_ioctl+0x5a/0x74
[<c04ab254>] ? do_vfs_ioctl+0x480/0x4ba
[<c0533031>] ? selinux_file_ioctl+0x3f/0x42
[<c04ab2d4>] ? sys_ioctl+0x46/0x66
[<c0403f72>] ? syscall_call+0x7/0xb
Code: c3 55 89 e5 57 89 cf 56 89 d6 53 89 c3 8b 41 04 39 d0 74 17 51 50 52 68 be 13 80 c0 6a 1a 68 73 13 80 c0 e8 c7 c6 ec ff 83 c4 18 <8b> 06 39 f8 74 17 56 50 57 68 0b 14 80 c0 6a 1e 68 73 13 80 c0 
EIP: [<c0562bb2>] __list_add+0x2a/0x5c SS:ESP 0068:f24c7d34
---[ end trace 4be3a51231dd9fd1 ]---
Comment 1 Maarten 2009-05-17 16:09:20 EDT
since last update system boots again. Don't know if this can call it fixed because I have had some similar unstable behaviour. But then not during boot. I can not reproduce this however. Sometimes X spontaneously logs out don't know if that is related. 

Switched distributions from ubuntu because that was even worse. As fedora has more recent ati drivers I was hoping it would be a better experience. And it is, but still not as good as it should be.
Comment 2 Chris Shoemaker 2009-05-22 22:34:49 EDT
Could you please note what version of the kernel no longer shows this behavior?
Comment 3 Maarten 2009-05-23 04:02:51 EDT
1. Package update which included kernel-2.6.29.3/140.fc1(i568)
2. kernel-2.6.29.3/140.fc1(i568) did not boot.
3. kernel-2.6.29.3/136.fc1(i568) older kernel selected in grub did boot.
4. worked with this kernel for about a week.
5. Package update but no kernel update.
6. Tried kernel-2.6.29.3/140.fc1(i568) again. And now it does boot.

so kernel-2.6.29.3/140.fc1(i568) is not showing this behaviour anymore.
Comment 4 Chuck Ebbert 2009-06-03 05:01:16 EDT
The fix was in the radeon driver
Comment 5 Maarten 2009-06-03 05:38:47 EDT
Thanks system feels more stable lately. +1 for open source video drivers. Keep up the good work. regards.

Note You need to log in before you can comment on or make changes to this bug.