Bug 501113 - Grubby doesn't work with anything but fedora kernels
Grubby doesn't work with anything but fedora kernels
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
11
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-16 11:01 EDT by Josef Bacik
Modified: 2010-01-12 10:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 10:32:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Bacik 2009-05-16 11:01:13 EDT
Description of problem:
Grubby will fail every single time doing a make install with a custom kernel, with some crap about not finding a valid template.  So if i copy an existing entry, fix it so it works with my custom built kernel, and then try to install a fedora kernel ever again, grubby will fail to put the grub entry in, again complaining about not finding a valid template.  This makes it very frustrating for anybody who does kernel development in Fedora because we're constantly having to remember to screw with grub to get it to boot into our kernel.  This worked fine until grubby showed up.  I should have filed a bz about this when grubby first showed up, but 2 releases later and its still not fixed so here it is now.

Version-Release number of selected component (if applicable):
grubby-6.0.84-1.fc11.x86_64

How reproducible:
Every miserable time

Steps to Reproduce:
1. build a custom kernel and run make install
2. try to install any kernel ever again after installing a custom kernel
  
Actual results:
Grub entry doesn't get put in

Expected results:
A freaking grub entry

Additional info:
I can reproduce this at will on any of my fedora boxes with grubby installed, so if you have problems reproducing let me know, I'd be happy to give you an address to ssh into so you can feel my pain.
Comment 1 Bug Zapper 2009-06-09 11:55:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Hans de Goede 2010-01-12 10:32:54 EST
This is a mass edit of all mkinitrd bugs.

Thanks for taking the time to file this bug report (and/or commenting on it).

As you may have heard in Fedora 12 mkinitrd has been replaced by dracut. In Fedora 12 the mkinitrd package is still around as some programs depend on
certain libraries it provides, but mkinitrd itself is no longer used.

In Fedora 13 mkinitrd will be removed completely. This means that all work
on initrd has stopped.

Rather then keeping mkinitrd bugs open and giving false hope they might get fixed we are mass closing them, so as to clearly communicate that no more work will be done on mkinitrd. We apologize for any inconvenience this may cause. 

If you are using Fedora 11 and are experiencing a mkinitrd bug you cannot work around, please upgrade to Fedora 12. If you experience problems with the initrd in Fedora 12, please file a bug against dracut.

Note You need to log in before you can comment on or make changes to this bug.