Bug 501122 - Sound volume is very low after reboot
Sound volume is very low after reboot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-16 13:22 EDT by Dimi Paun
Modified: 2010-03-02 01:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-02 01:31:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of sliders (835.41 KB, image/png)
2009-05-18 12:51 EDT, Dimi Paun
no flags Details
pacmd ls output (34.71 KB, text/plain)
2009-05-18 12:56 EDT, Dimi Paun
no flags Details
amixer -c0 output (5.30 KB, text/plain)
2009-05-18 15:17 EDT, Dimi Paun
no flags Details
alsa-info.sh --no-upload (275 bytes, text/plain)
2009-05-18 21:03 EDT, Dimi Paun
no flags Details
diff -u amixer_before.txt amixer_after.txt > amixer_diff.txt (3.11 KB, text/plain)
2009-05-18 21:03 EDT, Dimi Paun
no flags Details
amixer_before.txt (5.29 KB, text/plain)
2009-05-19 14:26 EDT, Dimi Paun
no flags Details
amixer_after.txt (5.31 KB, text/plain)
2009-05-19 14:27 EDT, Dimi Paun
no flags Details
alsa-info.sh --no-upload (33.73 KB, text/plain)
2009-05-20 11:21 EDT, Dimi Paun
no flags Details

  None (edit)
Description Dimi Paun 2009-05-16 13:22:40 EDT
Description of problem:
After I reboot, sound volume is very low, despite the fact that alsamixer shows all channels high. The PA's Volume control shows all channels maxed out at 100%, yet the Volume Control applet (what is this?) shows the volume low (Output: 29%, -64.93 dB Internal Audio), but moving the slider up does nothing to the sound level, and it comes back to the original place.

To add insult to injury, if you right-click on that same Volume Control you get two options: Mute and Sound Preferences. You click on Sound Preferences, and lo-and-behold yet _another_ slider (Output volume) is set to low. You turn this one to the max, sound gets a little louder, but not enough. Sure enough, the Volume Control applet continues to show the volume at 29% and it doesn't want to make it louder!

How many sliders and Volume Controls do we need?!? Not only now we no longer have the control that we used to have with the older VC, but we have an insane amount of sliders that don't work!
Comment 1 Terje Røsten 2009-05-17 17:07:49 EDT
I see this too, however just with some apps. 

To reproduce start a youtube video in Firefox *and* play some music with e.g. amarok.

Open Sound Preferences from right clicking the Volume Icon.

In Sound Preferences choose the Programs tab, now slide top Output Volume up and down. Amarok slider will will follow  Output Volume. Firefox will follow too, however here comes the bug: if volume goes down to 0% Firefox will be stuck here, it will not follow up again. You can quit Amarok and sound on Firefox
will still not follow Output Volume up, it's stuck. Muted forever untill
you use the slider in the Program tab fix it.

Might be a feature, however sounds like a bug to me.
Comment 2 Lennart Poettering 2009-05-17 19:43:28 EDT
Dimi, pavucontrol and g-v-c expose the same volume sliders. If you use alsamixer+pavucontrol or alsamixer+g-v-c you can control all sliders you ever could want to control.

Are you aware that PA has per-stream and per-device volumes? Also, PA will remember both per-stream and per-device settings across reboots. pavucontrol exposes per-device volume sliders in the "Output Devices" tab and per-stream volume sliders in the "Playback" tab. 

Dimi, as I understood despite playing around with both pavucontrol and alsamixer your audio is still not at bearable level? If so, and you are sure it's not some hw volume control outside of your sound card that is misconfigured? i.e. your hifi reack's volume and similar?

If notWhat kind of speakers do you have connected to your device? What kind of audio are you playing back?
Comment 3 Dimi Paun 2009-05-17 21:36:53 EDT
> Dimi, pavucontrol and g-v-c expose the same volume sliders. 

In theory. Here I see volume at 100% in pavucontrol while g-v-c reports it at 28%. Please see the original description of the problem.

> If you use alsamixer+pavucontrol or alsamixer+g-v-c you can control all 
> sliders you ever could want to control.

I know that, but I think that requiring normal users to use alsamixer (with a magical parameter of '-c0') is just out of the question. Nobody reasonable will find out about alsamixer, I've been using Linux exclusively for 13+ years, and I learnt about it just recently _after_ I've filed a bug report.

> Are you aware that PA has per-stream and per-device volumes? Also, PA will
> remember both per-stream and per-device settings across reboots. pavucontrol
> exposes per-device volume sliders in the "Output Devices" tab and per-stream
> volume sliders in the "Playback" tab. 

Yes, I am aware of all that, and I have already stated that all sliders in pavucontrol reports all such settings at 100%.

> Dimi, as I understood despite playing around with both pavucontrol and
> alsamixer your audio is still not at bearable level? 

It is not as loud as it should be. I can hear sound, but I have to turn on the volume on the speakers quite high (that is, increase the gain of the speaker's built-in amplifier). It is softer than it used to be before the reboot. And the fact that g-v-c reports the volume at 28% (immutable!) is quite telling and in sync with the sound I get out of the speakers.

> If so, and you are sure it's not some hw volume control outside of your sound 
> card that is misconfigured? i.e. your hifi reack's volume and similar?

Yes, I am sure, I've checked.

> If notWhat kind of speakers do you have connected to your device?

Logitech 5.1 speaker system. This is not where the problem lies, 
I am 99.99% sure.

> What kind of audio are you playing back?  

Flash (youtube videos) or Rhythmbox, same deal.
Comment 4 Lennart Poettering 2009-05-18 09:31:17 EDT
(In reply to comment #3)
> > Dimi, pavucontrol and g-v-c expose the same volume sliders. 
> 
> In theory. Here I see volume at 100% in pavucontrol while g-v-c reports it at
> 28%. Please see the original description of the problem.

Could you please get me a screenshot of that? I.e. both windows and how they differ?

> > If you use alsamixer+pavucontrol or alsamixer+g-v-c you can control all 
> > sliders you ever could want to control.
> 
> I know that, but I think that requiring normal users to use alsamixer (with a
> magical parameter of '-c0') is just out of the question. Nobody reasonable will
> find out about alsamixer, I've been using Linux exclusively for 13+ years, and
> I learnt about it just recently _after_ I've filed a bug report.

We had this discussion already on fedora-devel. And also, this is completely unrelated to the point here. 

> > Dimi, as I understood despite playing around with both pavucontrol and
> > alsamixer your audio is still not at bearable level? 
> 
> It is not as loud as it should be. I can hear sound, but I have to turn on the
> volume on the speakers quite high (that is, increase the gain of the speaker's
> built-in amplifier). It is softer than it used to be before the reboot. And the
> fact that g-v-c reports the volume at 28% (immutable!) is quite telling and in
> sync with the sound I get out of the speakers.

Immutable? Please eleraborate!

Could please include here a dump of the output of "pacmd ls" and of "alsactl -c0" when this happens?
Comment 5 Dimi Paun 2009-05-18 12:51:55 EDT
Created attachment 344480 [details]
Screenshot of sliders

Please not that for g-v-c I took too shots (one with the on-hover popup, one with the slider you get on click), and pasted them on the same image for brevity.
Comment 6 Dimi Paun 2009-05-18 12:53:50 EDT
About the g-v-c slider: you moves it up, it doesn't affect the sound volume at all, you dismiss it, you click again on it, the slider is in the original position. That's why I said immutable: no matter where you move it, it reverts back to the 28% position.
Comment 7 Dimi Paun 2009-05-18 12:55:28 EDT
[dimi@dimi ~]$ alsactl -c0 > alsactl-c0.out
alsactl: invalid option -- 'c'
Comment 8 Dimi Paun 2009-05-18 12:56:22 EDT
Created attachment 344483 [details]
pacmd ls output
Comment 9 Lennart Poettering 2009-05-18 14:59:31 EDT
Hmm, that the g-v-c slider and the one in the applet differ is certainly a gnome-media problem. Could you please file a bug against gnome-media about the fact that the differ and include this very screenshot and a link to this bug report?

Sorry for the alsactl confusion. I meant "amixer -c0". 

The pacmd output shows all streams/devices at 100%. Which is good. If you can get me that amixer -c0 output then we'll see if if the volume issue is caused by that.
Comment 10 Dimi Paun 2009-05-18 15:17:35 EDT
Created attachment 344505 [details]
amixer -c0 output
Comment 11 Dimi Paun 2009-05-18 15:20:01 EDT
But I must say, something changed maybe when I did the "pacmd ls", because the sound level now seems OK.... Still a bit softer but not as much as in the beginning. It's almost right. I've noticed that right after I did the pacmd ls.
Comment 12 Lennart Poettering 2009-05-18 17:20:28 EDT
Dimi, that amixer output suggests that you can still increase your PCM slider to 0db (100%). Please use "alsamixer" to do that.

Also, probably playing around with "Front" should increase your volume too.

Could you please follow these recommendations:

https://www.redhat.com/archives/fedora-devel-list/2009-April/msg02321.html

i.e. reset the mixer, via "alsactl init", then take a snapshot of it via "amixer -c0". Then try to fix it via "alsamixer -c0", by manipulating Front, Master, Headphone, PCM and Speaker. Then take another snapshot via "amixer -c0". Then attach those two amixer outputs and the output of "alsa-info.sh --no-upload" here.

This will allow us to include your sound card in the default mixer initialization database of ALSA and make sure the the card is properly configured by default.
Comment 13 Dimi Paun 2009-05-18 21:02:40 EDT
Yes, there was a _bit_ more volume that I could squeeze out of the alsamixer, but that wasn't it.

I have already submitted the data for the mixer:
   https://bugzilla.redhat.com/show_bug.cgi?id=493790

But I'll do it again...
Comment 14 Dimi Paun 2009-05-18 21:03:06 EDT
Created attachment 344537 [details]
alsa-info.sh --no-upload
Comment 15 Dimi Paun 2009-05-18 21:03:38 EDT
Created attachment 344538 [details]
diff -u amixer_before.txt amixer_after.txt > amixer_diff.txt
Comment 16 Dimi Paun 2009-05-18 21:04:24 EDT
But please note that it seems to me the alsactl init didn't reset the mixer levels to what they were after the reset...
Comment 17 Lennart Poettering 2009-05-19 09:29:35 EDT
In bug 493790 you said the mixer initialization was OK after that fix. 

Are you now saying it isn't anymore?
Comment 18 Dimi Paun 2009-05-19 11:04:42 EDT
Yes, that's what I'm saying. I don't know anymore: I boot one day, everything is fine, I boot again a few days later, it is not. I keep saying I see this sort of yo-yo behaviour for _years_, but nobody really cares.

Honestly Lennart, do you think this is OK?
Comment 19 Lennart Poettering 2009-05-19 14:00:00 EDT
(In reply to comment #18)
> Yes, that's what I'm saying. I don't know anymore: I boot one day, everything
> is fine, I boot again a few days later, it is not. I keep saying I see this
> sort of yo-yo behaviour for _years_, but nobody really cares.

Come on. This not fair. We do our best to handle your bug reports properly -- and do so for free! 

You have no right to complain that "nobody really cares". I handled all your bugs in great lengths. And if you felt I didn't you should have said something back when I closed that bug. Complaining now in retrospect is completely unfair.

I get the feeling that you are more interested in complaining than actually getting those bugs fixed. 

Free Software lives from contributions. If you really are the Linux professional you claim to be it should be possible to contribute something more and constructive than just moans and complaints on fedora-devel! Everything here is available in source. You have all the tools and you claim to have all the technical knowledge, too. You get help from us. For Free. That all should be enough to make things work. Yet, all you do is complain and make requests.

Honestly, Dimi, do you think this is OK?

As requested earlier, could you please attach both amixer outputs? Alternatively please redo the diff with -N 7 or similar to make sure we get more context so that we actually know which controls you modified. Thank you.
Comment 20 Dimi Paun 2009-05-19 14:25:56 EDT
OK, you have a point -- I do complain a lot about this particular problem. More so than I ever did, and while I don't like it myself, please realize that I have had innumerable problems for more than 7+ years! I reasonable person would have quit long before but I stuck around. That's a positive thing, but it comes at a price: unreasonable complaints :) 

Jokes aside,  I am very frustrated with the current situation, and try as I might, I will have frustrated reactions. For that I apologise in advance, but that's the situation. My last comment was harsh, I agree, but was prompted by your implication that I change my tune.

Now, it is very true that you have been very responsive to my bug reports, it is much appreciated. As for contributions from me, please realize that I'm at a point right now where all I can do is contribute feedbacks and bug reports. I'd definitely like to contribute code (as that's a lot more pleasurable to do), but I can not do that at this point. I think feedback, even if negative, is quite valuable.

Look man, bottom line I want you to succeed make PA work as it should. Believe me. I was one of your earliest (but silent) supporters. Did I even advocate to ditch PA? That being said I think your development priorities are wrong. For example, a while ago I bitched at your suggestion to 'just' run 'pulseaudio -D' whenever PA died. Since it died frequently in my case, I asked why not spawn it automagically. Even Alan Cox pitched in to suggest the same thing. You brushed us off saying it's too much work. Well, it ended up happening (not quite right, but still a step forward), but not without a lot of frustration from people suffering from PA dying on them.

Anyway, I'll go on record and say that I do appreciate your good nature and positive approach to all my bitching :)
Comment 21 Dimi Paun 2009-05-19 14:26:34 EDT
Created attachment 344666 [details]
amixer_before.txt
Comment 22 Dimi Paun 2009-05-19 14:27:01 EDT
Created attachment 344667 [details]
amixer_after.txt
Comment 23 Lennart Poettering 2009-05-20 10:52:32 EDT
(In reply to comment #20)

> Look man, bottom line I want you to succeed make PA work as it should. Believe
> me. I was one of your earliest (but silent) supporters. Did I even advocate to
> ditch PA? That being said I think your development priorities are wrong. For
> example, a while ago I bitched at your suggestion to 'just' run 'pulseaudio -D'
> whenever PA died. Since it died frequently in my case, I asked why not spawn it
> automagically. Even Alan Cox pitched in to suggest the same thing. You brushed
> us off saying it's too much work. 

I did? That is wrong, I didn't do that. The reason I didn't add this was that it hides bugs. "Too much work" is seldomly a valid excuse.

The reasons I added it after all is to support a11y people who have a good reason to use the console still, where PA cannot be started otherwise, since console logins lack a session manager.

> Well, it ended up happening (not quite right,
> but still a step forward), but not without a lot of frustration from people
> suffering from PA dying on them.

Not quite right? How so? Did you file a bug?
Comment 24 Lennart Poettering 2009-05-20 10:57:33 EDT
Also, let me note that the issues pointed out in this bug report are unrelated to PA itself.

amixer diff is;

--- a	2009-05-20 16:54:23.000000000 +0200
+++ b	2009-05-20 16:54:34.000000000 +0200
@@ -1,12 +1,12 @@
 Simple mixer control 'Master',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined
   Playback channels: Mono
   Limits: Playback 0 - 39
-  Mono: Playback 25 [64%] [-21.00dB] [on]
+  Mono: Playback 39 [100%] [0.00dB] [on]
 Simple mixer control 'Headphone',0
   Capabilities: pswitch
   Playback channels: Front Left - Front Right
   Mono:
   Front Left: Playback [on]
   Front Right: Playback [on]
 Simple mixer control 'PCM',0
@@ -24,35 +24,35 @@
   Front Left: Playback 39 [100%] [0.00dB] [on]
   Front Right: Playback 39 [100%] [0.00dB] [on]
 Simple mixer control 'Front Mic',0
   Capabilities: pvolume pswitch
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 31
   Mono:
-  Front Left: Playback 30 [97%] [10.50dB] [off]
-  Front Right: Playback 30 [97%] [10.50dB] [off]
+  Front Left: Playback 31 [100%] [12.00dB] [off]
+  Front Right: Playback 31 [100%] [12.00dB] [off]
 Simple mixer control 'Front Mic Boost',0
   Capabilities: volume
   Playback channels: Front Left - Front Right
   Capture channels: Front Left - Front Right
   Limits: 0 - 3
   Front Left: 3 [100%]
   Front Right: 3 [100%]
 Simple mixer control 'Surround',0
   Capabilities: pvolume pswitch
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 39
   Mono:
-  Front Left: Playback 38 [97%] [-1.50dB] [off]
-  Front Right: Playback 38 [97%] [-1.50dB] [off]
+  Front Left: Playback 39 [100%] [0.00dB] [off]
+  Front Right: Playback 39 [100%] [0.00dB] [off]
 Simple mixer control 'Center',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined
   Playback channels: Mono
   Limits: Playback 0 - 39
-  Mono: Playback 38 [97%] [-1.50dB] [off]
+  Mono: Playback 39 [100%] [0.00dB] [off]
 Simple mixer control 'LFE',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined
   Playback channels: Mono
   Limits: Playback 0 - 39
   Mono: Playback 39 [100%] [0.00dB] [off]
 Simple mixer control 'Side',0
   Capabilities: pvolume pswitch
@@ -90,16 +90,16 @@
   Front Left: 3 [100%]
   Front Right: 3 [100%]
 Simple mixer control 'IEC958',0
   Capabilities: pvolume cvolume pswitch pswitch-joined cswitch cswitch-joined
   Playback channels: Front Left - Front Right
   Capture channels: Front Left - Front Right
   Limits: Playback 0 - 39 Capture 0 - 31
-  Front Left: Playback 39 [100%] [0.00dB] [off] Capture 23 [74%] [0.00dB] [on]
-  Front Right: Playback 39 [100%] [0.00dB] [off] Capture 23 [74%] [0.00dB] [on]
+  Front Left: Playback 39 [100%] [0.00dB] [off] Capture 31 [100%] [12.00dB] [on]
+  Front Right: Playback 39 [100%] [0.00dB] [off] Capture 31 [100%] [12.00dB] [on]
 Simple mixer control 'IEC958 Default PCM',0
   Capabilities: pswitch pswitch-joined
   Playback channels: Mono
   Mono: Playback [on]
 Simple mixer control 'IEC958 Playback Source',0
   Capabilities: enum
   Items: 'PCM' 'ADC1' 'ADC2' 'ADC3'
@@ -116,36 +116,36 @@
   Limits: Capture 0 - 54
   Front Left: Capture 54 [100%] [22.50dB] [on]
   Front Right: Capture 54 [100%] [22.50dB] [on]
 Simple mixer control 'Capture',1
   Capabilities: cvolume cswitch
   Capture channels: Front Left - Front Right
   Limits: Capture 0 - 54
-  Front Left: Capture 39 [72%] [0.00dB] [off]
-  Front Right: Capture 39 [72%] [0.00dB] [off]
+  Front Left: Capture 54 [100%] [22.50dB] [off]
+  Front Right: Capture 54 [100%] [22.50dB] [off]
 Simple mixer control 'Capture',2
   Capabilities: cvolume cswitch
   Capture channels: Front Left - Front Right
   Limits: Capture 0 - 54
-  Front Left: Capture 39 [72%] [0.00dB] [off]
-  Front Right: Capture 39 [72%] [0.00dB] [off]
+  Front Left: Capture 54 [100%] [22.50dB] [off]
+  Front Right: Capture 54 [100%] [22.50dB] [off]
 Simple mixer control 'Analog Mix',0
   Capabilities: pvolume pswitch
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 31
   Mono:
   Front Left: Playback 31 [100%] [0.00dB] [on]
   Front Right: Playback 31 [100%] [0.00dB] [on]
 Simple mixer control 'Beep',0
   Capabilities: pvolume pswitch
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 15
   Mono:
   Front Left: Playback 15 [100%] [0.00dB] [off]
-  Front Right: Playback 0 [0%] [-45.00dB] [on]
+  Front Right: Playback 15 [100%] [0.00dB] [on]
 Simple mixer control 'Input Source',0
   Capabilities: cenum
   Items: 'Front Mic' 'Line' 'Mic' 'CD' 'Mix'
   Item0: 'Mic'
 Simple mixer control 'Input Source',1
   Capabilities: cenum
   Items: 'Front Mic' 'Line' 'Mic' 'CD' 'Mix'

I will now reassign this to alsa-libs. Since some (not all) of these changes are probably good candidates for inclusion in the ALSA mixer defaults db.

Dimi, before this can be useful for Jaroslav, could you please generate a proper alsa-info.sh --no-upload output? The one you attached is not useful.
Comment 25 Dimi Paun 2009-05-20 11:17:32 EDT
> I did? That is wrong, I didn't do that. The reason I didn't add this was that
> it hides bugs. "Too much work" is seldomly a valid excuse.

OK, let's leave it at that, I don't feel like going hunting through the archives... :)

> The reasons I added it after all is to support a11y people who have a good
> reason to use the console still, where PA cannot be started otherwise, since
> console logins lack a session manager.

Well, the reason should have also been reliability: expecting users to ever run 'pulseaudio -D' is just not reasonable, and at the time the thing was crashing regularly on my box. And besides, by you have the CPU hog detection code which by _design_ kills PA! So why not auto-restart it by design as well?

> > Well, it ended up happening (not quite right,
> > but still a step forward), but not without a lot of frustration from people
> > suffering from PA dying on them.

> Not quite right? How so? Did you file a bug?  

What I mean by "not quite right" is that after PA dies, Flash craps out. I know the "closed source" excuse, but IMO that doesn't cut it. Flash is so important these days that it requires a lot more attention than that.

This is in fact the crux of the problem when I complain about priorities: we should get PA to be rock solid _first_ for the usual cases (Flash, Skype, Rhythmbox, etc), and then worry about all the other tricks. Instead we now can do all sort of cool things with PA (liek merging streams, moving them around, etc.), but we can't listen reliably to a Youtube video. Deh.
Comment 26 Dimi Paun 2009-05-20 11:21:46 EDT
Created attachment 344828 [details]
alsa-info.sh --no-upload

Why do we have to do the song-and-dance with the alsa-info.sh --no-upload instead of just uploading a posting a link to the ALSA page?
Comment 27 Dimi Paun 2009-05-20 11:23:18 EDT
Oh, please note that I don't think this was the alsa mixer issue. As I said, the sound was soft, and at a certain point became louder. The tweaks in the mixer made little difference, as there I increased the volume from say 92 -> 100. It was something else.
Comment 28 Lennart Poettering 2009-05-20 13:53:23 EDT
> > Not quite right? How so? Did you file a bug?  
> 
> What I mean by "not quite right" is that after PA dies, Flash craps out. I know
> the "closed source" excuse, but IMO that doesn't cut it. Flash is so important
> these days that it requires a lot more attention than that.
> 
> This is in fact the crux of the problem when I complain about priorities: we
> should get PA to be rock solid _first_ for the usual cases (Flash, Skype,
> Rhythmbox, etc), and then worry about all the other tricks. Instead we now can
> do all sort of cool things with PA (liek merging streams, moving them around,
> etc.), but we can't listen reliably to a Youtube video. Deh.  

This is not the right place to discuss this. Please file bugs against Flash in the Adobe bug tracker if they have any. I refuse to let us be taken ransom by some closed source vendors which provide buggy software that I cannot fix.
Comment 29 Dimi Paun 2009-05-20 16:34:39 EDT
Lennart, this "I refuse to let us be taken ransom by some closed source vendors" is lame. Like it or not, we'll always have to deal with closed source software, not to mention that any software out there is buggy by definition.

But whatever, this is not the subject of this bug report. The bug is about low volume. Now volume is OK, and it sort of fixed itself somewhere along the way, most likely when I did the 'pacmd ls'.

And, and not to forget the volume slider stuck at 28%...
Comment 30 Lennart Poettering 2009-05-20 19:46:59 EDT
(In reply to comment #29)

> But whatever, this is not the subject of this bug report. The bug is about low
> volume. Now volume is OK, and it sort of fixed itself somewhere along the way,
> most likely when I did the 'pacmd ls'.

It's very unlikely that this got fixed by "pacmd ls".

> And, and not to forget the volume slider stuck at 28%...  

Did you file a seperate bug for that as requested?

Jaroslav, ignore all the other blurb here. The interesting part is the amixer diff shown in #24 that might include some fixes that perhaps should be in the alsa mixer init db.
Comment 31 Bug Zapper 2009-06-09 11:56:35 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 32 Dimi Paun 2010-03-02 01:31:59 EST
I have no longer seen this problem lately (currently running F12).

Note You need to log in before you can comment on or make changes to this bug.