Bug 501136 - Gwenview crashes oftern with SIGABRT
Gwenview crashes oftern with SIGABRT
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-16 18:19 EDT by Steve Snyder
Modified: 2009-05-30 22:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-30 22:58:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 190478 None None None Never

  None (edit)
Description Steve Snyder 2009-05-16 18:19:21 EDT
Description of problem:

Gwenview, the graphic file viewer in kdegraphics, often crashes with a SIGABRT when clicking the next-file icon

Version-Release number of selected component (if applicable):

$ rpm -qf /usr/bin/gwenview
kdegraphics-4.2.2-5.fc10.x86_64

How reproducible:

No clear sequence to reproduce.  The problem doesn't seem associated with any particular graphics file (though I am always viewing JPEGs when it happens).

Steps to Reproduce:
1.  Open a JPEG file in a directory with many JPEG files
2.  Use the next-picture icon to browse the files
3.  Crash may (or may not) occur on any given next-picture
  
Actual results:

Crashes with SIGABRT (see below).

Expected results:

Application should not crash.

Additional info:

Application: Gwenview (gwenview), signal SIGABRT
0x0000003deaea7f81 in nanosleep () from /lib64/libc.so.6
[Current thread is 1 (Thread 0x7f97e2b57810 (LWP 22205))]

Thread 4 (Thread 0x7f97dc181950 (LWP 22206)):
#0  0x0000003deaef497e in __lll_lock_wait_private () from /lib64/libc.so.6
#1  0x0000003deae7e235 in _L_lock_4781 () from /lib64/libc.so.6
#2  0x0000003deae7a47b in free () from /lib64/libc.so.6
#3  0x0000003df3e246e5 in ?? () from /lib64/libdbus-1.so.3
#4  0x0000003df3e1cf81 in ?? () from /lib64/libdbus-1.so.3
#5  0x0000003df3e0fb73 in dbus_connection_send_with_reply_and_block () from /lib64/libdbus-1.so.3
#6  0x0000003472e28633 in ?? () from /usr/lib64/libQtDBus.so.4
#7  0x0000003472e13803 in QDBusConnection::call () from /usr/lib64/libQtDBus.so.4
#8  0x0000003472e2eeef in QDBusAbstractInterface::callWithArgumentList () from /usr/lib64/libQtDBus.so.4
#9  0x0000003e7123f29c in Soprano::Client::DBusClient::createModel () from /usr/lib64/libsopranoclient.so.1
#10 0x0000003e71632e71 in ?? () from /usr/lib64/libnepomuk.so.4
#11 0x0000003e71632fc9 in ?? () from /usr/lib64/libnepomuk.so.4
#12 0x0000003e7162a76a in ?? () from /usr/lib64/libnepomuk.so.4
#13 0x0000003e7162a918 in ?? () from /usr/lib64/libnepomuk.so.4
#14 0x0000003e71643e62 in Nepomuk::Resource::property () from /usr/lib64/libnepomuk.so.4
#15 0x0000003e71644f1b in Nepomuk::Resource::rating () from /usr/lib64/libnepomuk.so.4
#16 0x0000003ae629532b in Gwenview::RetrieveTask::execute (this=0x111cb10) at /usr/src/debug/kdegraphics-4.2.2/gwenview/lib/semanticinfo/nepomuksemanticinfobackend.cpp:64
#17 0x0000003ae6295191 in Gwenview::SemanticInfoThread::run (this=0x1173560) at /usr/src/debug/kdegraphics-4.2.2/gwenview/lib/semanticinfo/nepomuksemanticinfobackend.cpp:142
#18 0x000000347165a602 in ?? () from /usr/lib64/libQtCore.so.4
#19 0x0000003deba073da in start_thread () from /lib64/libpthread.so.0
#20 0x0000003deaee62bd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f97d8a5d950 (LWP 22207)):
#0  0x0000003deba0b58d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x000000347165b5b7 in QWaitCondition::wait () from /usr/lib64/libQtCore.so.4
#2  0x0000003471651149 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x000000347165a602 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x0000003deba073da in start_thread () from /lib64/libpthread.so.0
#5  0x0000003deaee62bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f97d3f75950 (LWP 22215)):
#0  0x0000003deba0b58d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x000000347165b5b7 in QWaitCondition::wait () from /usr/lib64/libQtCore.so.4
#2  0x0000003471651149 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x000000347165a602 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x0000003deba073da in start_thread () from /lib64/libpthread.so.0
#5  0x0000003deaee62bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f97e2b57810 (LWP 22205)):
[KCrash Handler]
#5  0x0000003deae32f05 in raise () from /lib64/libc.so.6
#6  0x0000003deae34a73 in abort () from /lib64/libc.so.6
#7  0x0000003deae72438 in __libc_message () from /lib64/libc.so.6
#8  0x0000003deae77ec8 in malloc_printerr () from /lib64/libc.so.6
#9  0x0000003deae7a486 in free () from /lib64/libc.so.6
#10 0x0000003472e26008 in ?? () from /usr/lib64/libQtDBus.so.4
#11 0x00000034717529fd in QObject::event () from /usr/lib64/libQtCore.so.4
#12 0x0000003e6818e44d in QApplicationPrivate::notify_helper () from /usr/lib64/libQtGui.so.4
#13 0x0000003e681965ea in QApplication::notify () from /usr/lib64/libQtGui.so.4
#14 0x0000003e6a0068bb in KApplication::notify () from /usr/lib64/libkdeui.so.5
#15 0x000000347174296b in QCoreApplication::notifyInternal () from /usr/lib64/libQtCore.so.4
#16 0x00000034717435d1 in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib64/libQtCore.so.4
#17 0x000000347176c203 in ?? () from /usr/lib64/libQtCore.so.4
#18 0x000000346ee3762a in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#19 0x000000346ee3aded in ?? () from /lib64/libglib-2.0.so.0
#20 0x000000346ee3afab in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#21 0x000000347176be8f in QEventDispatcherGlib::processEvents () from /usr/lib64/libQtCore.so.4
#22 0x0000003e68224c3f in ?? () from /usr/lib64/libQtGui.so.4
#23 0x0000003471741212 in QEventLoop::processEvents () from /usr/lib64/libQtCore.so.4
#24 0x00000034717415dd in QEventLoop::exec () from /usr/lib64/libQtCore.so.4
#25 0x0000003471743894 in QCoreApplication::exec () from /usr/lib64/libQtCore.so.4
#26 0x000000000043ad93 in main (argc=6, argv=0x7fffeabaa768) at /usr/src/debug/kdegraphics-4.2.2/gwenview/app/main.cpp:95
Comment 1 Steve Snyder 2009-05-16 18:21:16 EDT
See also: https://bugs.kde.org/show_bug.cgi?id=190478
Comment 2 Rex Dieter 2009-05-16 19:12:20 EDT
triaged.
Comment 3 Steve Snyder 2009-05-16 20:08:26 EDT
(In reply to comment #2)
> triaged.  

What does that mean in practical terms?

I was seeing this in v4.2.1 and let it slide, figuring that it would be fixed in the next release.  It wasn't.  So, does "triaged" mean here that the bug won't be fixed due to scheduling reasons?  That it will be set aside until v4.3.0?  That Gwenview itself will be removed from kdegraphics?
Comment 4 Kevin Kofler 2009-05-16 21:40:09 EDT
"triaged" just means we acknowledged the bug as valid and not a duplicate.

Most likely it will have to be fixed by upstream, where it is already reported.
Comment 5 Steven M. Parrish 2009-05-30 22:49:26 EDT
Since this has been reported upstream going to close this for now.  We will monitor the upstream report for a resolution.
Comment 6 Kevin Kofler 2009-05-30 22:58:03 EDT
Then let's actually close it rather than setting needinfo. ;-)

Note You need to log in before you can comment on or make changes to this bug.