Bug 501157 - file dialog doesn't clearly show what directory you're looking at.
file dialog doesn't clearly show what directory you're looking at.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 06:17 EDT by David Woodhouse
Modified: 2009-05-17 17:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-17 17:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-05-17 06:17:34 EDT
I had an interesting phone call from my father this morning, who was confused by the GTK file dialog box. Upon looking harder, I understand the cause of his confusion.

If you go deep into a directory hierarchy, the names of the directories you've entered are shown on the screen, each in a little box. New boxes are added on the right-hand side as you enter new directories.

If you then come back _up_ to a parent directory, those boxes on the right-hand side don't go away. See screenshot at http://david.woodhou.se/filedlg.png for example -- it's actually looking at the ~/Download/ directory but you could be forgiven for thinking that it's in the ~/Download/solos-pci-0.07/soloscli/ directory.

After returning to a parent directory, why do we keep the old subdirectory on the screen? It's just confusing -- the fact that the actually selected directory is a 'pressed' button, and has bold text, is really not enough of a hint.

Ideally, those old subdirectories should go away completely when we leave them. Or if we _really_ want the user to be able to go back to them quickly without having to find them in the list again, maybe we have a tiny right-arrow button which goes back down a level, or grey them out or something.

Anything, really, to stop them being so confusingly prominent.
Comment 1 Matthias Clasen 2009-05-17 17:26:35 EDT
> it's actually looking at the ~/Download/ directory but you could be
> forgiven for thinking that it's in the ~/Download/solos-pci-0.07/soloscli/
> directory.

Sure, the user is always forgiven...

> After returning to a parent directory, why do we keep the old subdirectory on
> the screen? It's just confusing -- the fact that the actually selected
> directory is a 'pressed' button, and has bold text, is really not enough of a
> hint.

This is the first time I hear this complaint. Bold and depressed is a pretty strong and pretty standard way to indicate the current element, I'd say. 

> Ideally, those old subdirectories should go away completely when we leave them.

No. The reason we keep them around until you go down into another branch of the tree is for visual continuity, and for allowing you to go back and forth between a directory and its ancestors without constantly having to find the directory again in the file list.

Nautilus has exactly the same location bar behaviour, btw.

If you want to pursue this further, please take it upstream.

Note You need to log in before you can comment on or make changes to this bug.