Bug 501158 - Webcam detection wrong
Webcam detection wrong
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 06:20 EDT by analyzer
Modified: 2009-06-06 14:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 03:10:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description analyzer 2009-05-17 06:20:21 EDT
I have got an integrated webcam on a MSI GX700 laptop, which is not recognized correctly.

Linux fedorabox 2.6.29.2-52.fc10.i686 #1 SMP Mon Apr 27 16:29:14 EDT 2009 i686 i686 i386 GNU/Linux

Bus 001 Device 002: ID 0402:5602 ALi Corp. Video Camera Controller

/var/log/messages:
May 17 11:57:57 localhost kernel: gspca: probing 0402:5602
May 17 11:57:57 localhost kernel: ALi m5602: Probing for a po1030 sensor
May 17 11:57:57 localhost kernel: ALi m5602: Probing for a mt9m111 sensor
May 17 11:57:57 localhost kernel: ALi m5602: Probing for a s5k4aa sensor
May 17 11:57:57 localhost kernel: ALi m5602: Probing for an ov9650 sensor
May 17 11:57:57 localhost kernel: ALi m5602: Probing for a s5k83a sensor
May 17 11:57:57 localhost kernel: ALi m5602: Detected a s5k83a sensor
May 17 11:57:58 localhost kernel: gspca: probe ok
May 17 11:57:58 localhost kernel: usbcore: registered new interface driver ALi m5602
May 17 11:57:58 localhost kernel: ALi m5602: registered

In fact, my sensor is a s5k4aa, not a s5k83a.

Because of this, cheese only displays a quarter of the image.
Comment 1 Chuck Ebbert 2009-05-18 02:20:22 EDT
This is probably happening in Fedora 11 too.
Comment 2 Hans de Goede 2009-05-18 03:10:13 EDT
The ALi m5602 driver in the kernel is actively maintained by Erik Andrén, so I believe this is best handled upstream I'll forward this ticket to Erik, putting
the reporter in the CC (I hope the used email address atleast works somewhat).
Comment 3 Erik Andrén 2009-05-18 03:35:39 EDT
Hi,
Could you please see if the latest upstream version works ok by following the instructions on this wiki page?

http://m560x-driver.wiki.sourceforge.net/testing_m5602

Thanks,
Erik
Comment 4 analyzer 2009-05-26 17:03:35 EDT
I think it works, since I worked on that detection with you long time ago (anaHimself).

Will wait for next kernel in testing and keep you in touch :)
Comment 5 analyzer 2009-06-06 14:42:03 EDT
Linux fedorabox 2.6.29.4-75.fc10.i686

Jun  6 20:33:16 localhost kernel: ALi m5602: Probing for a po1030 sensor
Jun  6 20:33:16 localhost kernel: ALi m5602: Probing for a mt9m111 sensor
Jun  6 20:33:16 localhost kernel: ALi m5602: Probing for a s5k4aa sensor
Jun  6 20:33:16 localhost kernel: ALi m5602: Probing for an ov9650 sensor
Jun  6 20:33:16 localhost kernel: ALi m5602: Probing for a s5k83a sensor
Jun  6 20:33:16 localhost kernel: ALi m5602: Detected a s5k83a sensor
Jun  6 20:33:16 localhost kernel: gspca: probe ok
Jun  6 20:33:16 localhost kernel: usbcore: registered new interface driver ALi m5602
Jun  6 20:33:16 localhost kernel: ALi m5602: registered


Black image with cheese this new kernel, waiting for others in testing

Note You need to log in before you can comment on or make changes to this bug.