Bug 501170 - evince (poppler?) doesn't display correct checkbox status on OpenOffice.org exported .pdf (but acroread can)
evince (poppler?) doesn't display correct checkbox status on OpenOffice.org e...
Status: CLOSED DUPLICATE of bug 480868
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On: 480868
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 08:58 EDT by Peng Huang
Modified: 2009-09-23 11:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 480868
Environment:
Last Closed: 2009-09-23 11:32:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peng Huang 2009-05-17 08:58:18 EDT
+++ This bug was initially created as a clone of Bug #480868 +++

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5

Export to pdf loses the status (eg. checked or unchecked) of tickboxes, checkboxes, etc.

Reproducible: Always

Steps to Reproduce:
1.View -> Toolbars -> Form Controls
2.Add a checkbox
3.Tick checkbox
4.File -> Export as PDF (choose default settings)
Actual Results:  
1. Checkbox and text exported to pdf.
2. All checkboxes are unticked.

Expected Results:  
1. Checkbox and text exported to pdf.
2. Checkbox status (ticked or not) same as in OO writer.

Build Date: Sat 08 Nov 2008 12:55:39 AM EST
Source RPM: openoffice.org-3.0.0-9.10.fc10.src.rpm

--- Additional comment from anross@redhat.com on 2009-01-20 19:06:03 EDT ---

Created an attachment (id=329520)
Sample OOo writer doc

--- Additional comment from anross@redhat.com on 2009-01-20 19:06:38 EDT ---

Created an attachment (id=329521)
Sample Export PDF output

--- Additional comment from caolanm@redhat.com on 2009-01-21 04:38:31 EDT ---

Actually, if I open that output .pdf in acroread then the checkboxs *are* ticked, but when opened in evince I get

> evince input.pdf 
Error: Missing 'Tf' operator in field's DA string
Error: Unknown font in field's DA string
Error: Missing 'Tf' operator in field's DA string
Error: Unknown font in field's DA string

and they are not checked.

--- Additional comment from caolanm@redhat.com on 2009-01-21 04:39:15 EDT ---

Created an attachment (id=329571)
a pic of evince vs acroread side by side
Comment 1 Bug Zapper 2009-06-09 11:58:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Caolan McNamara 2009-09-23 11:32:30 EDT

*** This bug has been marked as a duplicate of bug 480868 ***

Note You need to log in before you can comment on or make changes to this bug.