Bug 501193 - bug during disk configuration
bug during disk configuration
Status: CLOSED DUPLICATE of bug 497911
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:6755298491cab1d3a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 16:01 EDT by Fabien Georget
Modified: 2009-05-18 10:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 10:14:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (176.80 KB, text/plain)
2009-05-17 16:06 EDT, Fabien Georget
no flags Details

  None (edit)
Description Fabien Georget 2009-05-17 16:01:19 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/partitioning.py", line 917, in growPartitions
    if not limited[part.name]:
  File "/usr/lib/anaconda/storage/partitioning.py", line 567, in doPartitioning
    growPartitions(disks, partitions)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1005, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1113, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1068, in editCB
    self.editPartition(device)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 943, in treeActivateCB
    self.editCB()
KeyError: 'sda1'
Comment 1 Fabien Georget 2009-05-17 16:06:24 EDT
Created attachment 344354 [details]
Attached traceback automatically from anaconda.
Comment 2 Fabien Georget 2009-05-17 16:11:17 EDT
This bug occured when I try to configure partitions. This is during an install of a virtual machine with virt-manager.

I want 4 disks : vda1 (/), sda1 (/usr), sda2 (/var), sda4 (/home).

Ananconda doesn't configure disk like I want and if i try to correct, anaconda report above exception.
Comment 3 Fabien Georget 2009-05-17 16:25:45 EDT
sorry for spam ...

*I want 4 disks : vda1 (/), sda1 (/usr), sda2 (/var), sda4 (/home).*
Is not correct, this is the correct sentence :
*I want 4 disks : vda1 (/), sda (/usr), sdb (/var), sdd (/home). 


I understand something, it is when I not select a disk (vda, sda, sdb or sdc) for my partition. It is created on the bad disk (of course), but I can't create an other partition after, the exception is raised.
Comment 4 Chris Lumens 2009-05-18 10:14:47 EDT

*** This bug has been marked as a duplicate of bug 497911 ***

Note You need to log in before you can comment on or make changes to this bug.