Bug 501202 - asciidoc doesn't handle multiple man pages in one file for docbook output
asciidoc doesn't handle multiple man pages in one file for docbook output
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: asciidoc (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
http://groups.google.com/group/asciid...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-17 19:39 EDT by Peter Hutterer
Modified: 2009-06-19 01:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-19 01:11:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Handle-multiple-man-pages-in-docbook-output.patch (2.06 KB, patch)
2009-05-17 19:39 EDT, Peter Hutterer
no flags Details | Diff

  None (edit)
Description Peter Hutterer 2009-05-17 19:39:40 EDT
Created attachment 344362 [details]
0001-Handle-multiple-man-pages-in-docbook-output.patch

Description of problem:

An asciidoc file that describes several man pages in the same file does not generate the right XML file output. 

From http://groups.google.com/group/asciidoc/browse_thread/thread/c93bb4db025225d8?pli=1

"Using the following NAME section, a2x creates "foo,_bar.1" as output
file instead of the intended "foo.1".

  NAME
  ----
  foo, bar - Do some foo 

[...]

  The problem stems from the fact that AsciiDoc puts both the names into a
single DocBook refname element:

     <refname>foo, bar</refname>

Instead of:

     <refname>foo</refname>
     <refname>bar</refname>

The latter is semantically correct and when processed generates two man
page files [...]"


Steps to Reproduce:
1. Take a asciidoc file as above 
2. asciidoc -b docbook -d manpage file.txt
3. xmlto man file.xml

Actual results:
The resulting man page is a single man page foo,_bar.1. 
  
Expected results:
Two man pages foo.1 and bar.1.

Additional info:
The fix for this went upstream http://hg.sharesource.org/asciidoc/raw-rev/fc5a653a30a3. Attached is the backported fix for F-11/rawhide.
Comment 1 Bug Zapper 2009-06-09 12:00:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Peter Hutterer 2009-06-19 01:11:55 EDT
Fixed in rawhide with version 8.4.5

Note You need to log in before you can comment on or make changes to this bug.