Bug 501249 - link not up with forcedeth drivers with kernel > 2.6.29.3-140
link not up with forcedeth drivers with kernel > 2.6.29.3-140
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 04:41 EDT by Eelko Berkenpies
Modified: 2009-05-21 16:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 20:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eelko Berkenpies 2009-05-18 04:41:53 EDT
Description of problem:
Link is not getting ready 

Version-Release number of selected component (if applicable):
2.6.29.3-140

How reproducible:
Always

Steps to Reproduce:
1. boot up kernel 2.6.29.3-140 or 2.6.29.3-142 (koji)
  
Actual results:
no link detected

Expected results:
link detected

Additional info:

lspci:
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)

messages:
May 18 08:36:52 gerwin kernel: forcedeth 0000:00:14.0: ifname eth0, PHY OUI 0x5043 @ 1, addr 00:1d:60:0e:46:56
May 18 08:36:52 gerwin kernel: eth0: no link during initialization. 
May 18 08:36:52 gerwin kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready

ethtool eth0 also tells me there is no link. 

We have another desktop with a nforce chipset too which has the same problem. Booting the system back to 2.6.29.2-126 does "fix" the problem
Comment 1 Kyle McMartin 2009-05-18 13:10:10 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=1361240

please try the scratch build here when it completes.
Comment 2 Gerwin Krist 2009-05-19 06:09:33 EDT
Seems to be fixed in the .146 build, thanks for fixing Kyle :)

Note You need to log in before you can comment on or make changes to this bug.