Bug 50133 - rpm-4.0.3-0.69 fails
rpm-4.0.3-0.69 fails
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-26 22:45 EDT by sean
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-25 20:51:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2001-07-26 22:45:44 EDT
Description of Problem:
Two problems maybe related?

1. 
[root@localhost tmp]# rpm --rebuild gal-0.8.5.src.rpm
/usr/lib/rpm/rpmb: error while loading shared libraries: /usr/lib/rpm/rpmb:
undefined symbol: poptAliasOptions

2.
[root@localhost rawhide]# rpm -Fvh rpm*69.i386*                
Preparing...                ###########################################
[100%]
   1:rpm                    ########################################### [
100%]
/sbin/ldconfig: file /usr/lib/libdb_cxx-3.2.so;3b3cd019 is truncated

/sbin/ldconfig: /usr/lib/librpmio-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpmdb-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpm-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpmbuild-4.0.3.so is not a symbolic link


I tried to go back to 4.0.3-0.66, but I got the same problems.  4.0.3-0.66
was working fine. 

Also,  the libdb_cxx is truncated message is _not_  new. It arose after a
db3 upgrade some time ago.


How Reproducible:
 
see above

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jeff Johnson 2001-07-27 23:12:42 EDT
You've not upgraded the popt sub-package of rpm when you
upgraded rpm.
Comment 2 sean 2001-07-29 22:12:45 EDT
OK.  Got popt. I no longer get the rpm build error. I do, however, still get the
ldconfig error, which I didn't before 0.69. Is this just harmless error? I'm
running glibc 2.2.3-13.

thanks
jay

[root@localhost lib]# ldconfig
ldconfig: file /usr/lib/libdb_cxx-3.2.so;3b3cd019 is truncated

ldconfig: /usr/lib/librpmio-4.0.3.so is not a symbolic link

ldconfig: /usr/lib/librpmdb-4.0.3.so is not a symbolic link

ldconfig: /usr/lib/librpm-4.0.3.so is not a symbolic link

ldconfig: /usr/lib/librpmbuild-4.0.3.so is not a symbolic link

[root@localhost lib]# ls /usr/lib/librpm* -l
-rwxr-xr-x    1 root     root       285613 Jul 26 18:32 /usr/lib/librpm-4.0.3.so
-rw-r--r--    1 root     root       364522 Jul 26 18:32 /usr/lib/librpm.a
-rwxr-xr-x    1 root     root       119380 Jul 26 18:32
/usr/lib/librpmbuild-4.0.3.so
-rw-r--r--    1 root     root       154748 Jul 26 18:32 /usr/lib/librpmbuild.a
-rw-r--r--    1 root     root          734 Jul 26 18:32 /usr/lib/librpmbuild.la
lrwxrwxrwx    1 root     root           20 Jul 29 22:02 /usr/lib/librpmbuild.so
-> librpmbuild-4.0.3.so-rwxr-xr-x    1 root     root       119380 Jul 11 01:17
/usr/lib/librpmbuild.so.0
-rwxr-xr-x    1 root     root      1964909 Jul 26 18:32
/usr/lib/librpmdb-4.0.3.so
-rw-r--r--    1 root     root      9251574 Jul 26 18:32 /usr/lib/librpmdb.a
-rw-r--r--    1 root     root          715 Jul 26 18:32 /usr/lib/librpmdb.la
lrwxrwxrwx    1 root     root           17 Jul 29 22:02 /usr/lib/librpmdb.so ->
librpmdb-4.0.3.so
-rwxr-xr-x    1 root     root      1964909 Jul 11 01:17 /usr/lib/librpmdb.so.0
-rwxr-xr-x    1 root     root       114034 Jul 26 18:32
/usr/lib/librpmio-4.0.3.so
-rw-r--r--    1 root     root       134966 Jul 26 18:32 /usr/lib/librpmio.a
-rw-r--r--    1 root     root          741 Jul 26 18:32 /usr/lib/librpmio.la
lrwxrwxrwx    1 root     root           17 Jul 29 22:02 /usr/lib/librpmio.so ->
librpmio-4.0.3.so
-rwxr-xr-x    1 root     root       114034 Jul 11 01:17 /usr/lib/librpmio.so.0
-rw-r--r--    1 root     root          716 Jul 26 18:32 /usr/lib/librpm.la
lrwxrwxrwx    1 root     root           15 Jul 29 22:02 /usr/lib/librpm.so ->
librpm-4.0.3.so
-rwxr-xr-x    1 root     root       285613 Jul 26 18:32 /usr/lib/librpm.so.0
Comment 3 Jeff Johnson 2001-07-30 09:36:17 EDT
You need to fix problems due to a partial rpm install. Run ldconfig
from the command line, remove (or copy someplace if you're paranoid)
and repeat until ldconfig doesn't complain. Then reinstall the packages
that are associated with the problem files.

Yes, several of the files are from rpm packages. /bin/rpm is statically
linked, reinstall all the rpm packages using --force.
Comment 4 sean 2001-08-25 20:51:14 EDT
I may be doing something really stupid, but the rpm install is recreating these
files that give ldconfig fits.

I. I got rid of the offending files, and ldconfig was happy.

 root@localhost lib]# ls *0.3.so
librpm-4.0.3.so  librpmbuild-4.0.3.so  librpmdb-4.0.3.so  librpmio-4.0.3.so
[root@localhost lib]# mv  *0.3.so rpmsave/
[root@localhost lib]# ls *0.3.so
ls: *0.3.so: No such file or directory
[root@localhost lib]# ldconfig
ldconfig: file /usr/lib/libdb_cxx-3.2.so;3b3cd019 is truncated
[root@localhost lib]# cd /opt/7.1/rawhide

2. Then I installed rpm-4.0.3-0.91. No complaint on the install, but it
recreated the offending files, and the ldconfig error was back.

[root@localhost rawhide]# ls *0.91*
popt-1.6.3-0.91.i386.rpm  rpm-build-4.0.3-0.91.i386.rpm 
rpm-python-4.0.3-0.91.i386.rpm
rpm-4.0.3-0.91.i386.rpm   rpm-devel-4.0.3-0.91.i386.rpm
rpm-4.0.3-0.91.src.rpm    rpm-perl-4.0.3-0.91.i386.rpm
[root@localhost rawhide]# rpm -Uvh *0.91* --force
Preparing...                ########################################### [100%]
   1:popt                   ########################################### [ 16%]
/sbin/ldconfig: file /usr/lib/libdb_cxx-3.2.so;3b3cd019 is truncated

   2:rpm                    ########################################### [ 33%]
/sbin/ldconfig: file /usr/lib/libdb_cxx-3.2.so;3b3cd019 is truncated

/sbin/ldconfig: /usr/lib/librpmio-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpmdb-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpm-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpmbuild-4.0.3.so is not a symbolic link

   3:rpm-build              ########################################### [ 50%]
   4:rpm-devel              ########################################### [ 66%]
/sbin/ldconfig: file /usr/lib/libdb_cxx-3.2.so;3b3cd019 is truncated

/sbin/ldconfig: /usr/lib/librpmio-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpmdb-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpm-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpmbuild-4.0.3.so is not a symbolic link

   5:rpm-perl               ########################################### [ 83%]
   6:rpm-python             ########################################### [100%]
/sbin/ldconfig: file /usr/lib/libdb_cxx-3.2.so;3b3cd019 is truncated

/sbin/ldconfig: /usr/lib/librpmio-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpmdb-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpm-4.0.3.so is not a symbolic link

/sbin/ldconfig: /usr/lib/librpmbuild-4.0.3.so is not a symbolic link

   7:rpm                    ########################################### [116%]

3. Can I just get rid of these files and live happily ever after??
Comment 5 Jeff Johnson 2001-08-30 13:31:55 EDT
I believe there's a "hidden" problem installing rpm-4.0.3-0.91,
the error message for a failed payload unpack was not being
displayed correctly until rpm-4.0.3-0.99 (or thereabouts).
Try installing rpm-4.0.3-1.00 (or later) to see if there really
is some other error here.

Otherwise, I can't think of anything else to try, so I'm gonna close
this bug. Feel free to reopen if you have more information regarding
the problem.

Note You need to log in before you can comment on or make changes to this bug.