Bug 501332 - Anaconda crush when trying to upgrade to Fedora 11-Preview
Anaconda crush when trying to upgrade to Fedora 11-Preview
Status: CLOSED DUPLICATE of bug 496529
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 11:43 EDT by Krzysztof Adamski
Modified: 2009-06-03 09:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-01 18:52:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exception report (155.26 KB, text/plain)
2009-05-18 11:43 EDT, Krzysztof Adamski
no flags Details

  None (edit)
Description Krzysztof Adamski 2009-05-18 11:43:30 EDT
Created attachment 344460 [details]
Exception report

Description of problem:
Anaconda crushes with unhandled exception when trying to upgrade from my Fedora 10 installation to Fedora 11-Preview from netinstall CD.

How reproducible:
On my setup, always.

Steps to Reproduce:
1. Boot netinstall CD.
2. Select upgrade option
3. Select logical volume with Fedora 10
4. Click next
  
Actual results:
Unhandled exception (report attached).

Expected results:
Clean upgrade.

Additional info:
Full install did work. I've created new LV (fedoratest) and done clean install. Upgrading F10 (fedora) failed every time (tried 3 times).

Here are some informations about my setup (run from newly installed F11):
# lvdisplay
  --- Logical volume ---
  LV Name                /dev/VGST3120026A/fedora
  VG Name                VGST3120026A
  LV UUID                zPPOc0-qdqE-riMy-35ep-oxe2-VIja-cSdM5U
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                39.28 GB
  Current LE             1257
  Segments               2
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:0
   
  --- Logical volume ---
  LV Name                /dev/VGST3120026A/home
  VG Name                VGST3120026A
  LV UUID                EIzYmD-P9Ba-cISF-sMlW-jPpI-Ge37-2YG79N
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                24.53 GB
  Current LE             785
  Segments               2
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:1

  --- Logical volume ---
  LV Name                /dev/VGST3120026A/gentoo
  VG Name                VGST3120026A
  LV UUID                RAHqAI-L0PX-mmJh-Nw3u-JcH1-eU8c-eEfAvL
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                10.00 GB
  Current LE             320
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:3
   
  --- Logical volume ---
  LV Name                /dev/VGST3120026A/blah
  VG Name                VGST3120026A
  LV UUID                7OEiHE-a77N-JdaO-RK0F-cNHr-91Wz-4SLUca
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                10.00 GB
  Current LE             320
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:4
   
  --- Logical volume ---
  LV Name                /dev/VGST3120026A/fedoratest
  VG Name                VGST3120026A
  LV UUID                59PYDx-2Rit-C2h2-Wqta-9GF4-m08R-Kw4auq
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                9.78 GB
  Current LE             313
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:5

# pvdisplay 
  --- Physical volume ---
  PV Name               /dev/sda2
  VG Name               VGST3120026A
  PV Size               111.60 GB / not usable 2.86 MB
  Allocatable           yes 
  PE Size (KByte)       32768
  Total PE              3571
  Free PE               514
  Allocated PE          3057
  PV UUID               7fdYqC-2JKF-uLhf-z10s-RCi8-3ZxI-6scUrN

# ls -l /dev/disk/by-id/
total 0
lrwxrwxrwx. 1 root root  9 2009-05-18 17:05 ata-ST3120026A_3JT1G6WP -> ../../sda
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 ata-ST3120026A_3JT1G6WP-part1 -> ../../sda1
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 ata-ST3120026A_3JT1G6WP-part2 -> ../../sda2
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-name-VGST3120026A-blah -> ../../dm-4
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-name-VGST3120026A-fedora -> ../../dm-0
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-name-VGST3120026A-fedoratest -> ../../dm-5
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-name-VGST3120026A-gentoo -> ../../dm-3
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-name-VGST3120026A-home -> ../../dm-1
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-name-VGST3120026A-swap -> ../../dm-2
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-uuid-LVM-C0EVP8oUoLrR2rkBrUVPtSTaNFCfIQUI59PYDx2RitC2h2Wqta9GF4m08RKw4auq -> ../../dm-5
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-uuid-LVM-C0EVP8oUoLrR2rkBrUVPtSTaNFCfIQUI7OEiHEa77NJdaORK0FcNHr91Wz4SLUca -> ../../dm-4
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-uuid-LVM-C0EVP8oUoLrR2rkBrUVPtSTaNFCfIQUIEIzYmDP9BacISFsMlWjPpIGe372YG79N -> ../../dm-1
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-uuid-LVM-C0EVP8oUoLrR2rkBrUVPtSTaNFCfIQUIkn2sRwgmr7pti6VcBaaFMrp2xmi30HGy -> ../../dm-2
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-uuid-LVM-C0EVP8oUoLrR2rkBrUVPtSTaNFCfIQUIRAHqAIL0PXmmJhNw3uJcH1eU8ceEfAvL -> ../../dm-3
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 dm-uuid-LVM-C0EVP8oUoLrR2rkBrUVPtSTaNFCfIQUIzPPOc0qdqEriMy35epoxe2VIjacSdM5U -> ../../dm-0
lrwxrwxrwx. 1 root root  9 2009-05-18 17:05 scsi-SATA_ST3120026A_3JT1G6WP -> ../../sda
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 scsi-SATA_ST3120026A_3JT1G6WP-part1 -> ../../sda1
lrwxrwxrwx. 1 root root 10 2009-05-18 17:05 scsi-SATA_ST3120026A_3JT1G6WP-part2 -> ../../sda2

What else could be helpful?
Comment 1 Chris Lumens 2009-05-18 11:50:29 EDT
Do you have a swap file listed in /etc/fstab?
Comment 2 Krzysztof Adamski 2009-05-18 14:54:42 EDT
Seems like this is source of problem:
$ cat /etc/fstab 
/dev/VGST3120026A/fedora /                       ext3    defaults        1 1
/dev/VGST3120026A/home  /home                   ext3    defaults        1 2
UUID=3c747db0-3b7f-4385-a32c-2d4bff643773 /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VGST3120026A/swap  swap                    swap    defaults        0 0
/dev/VG00/LV01          swap                    swap    defaults        0 0

I don't know where did this last line came from... but it looks like it's causing the problem. I think that installer should be able to handle such situation anyway (like ignore all nonexisting entries in /etc/fstab). Thanks for finding solution so quickly.
Comment 3 Andy Lindeberg 2009-06-03 09:54:10 EDT

*** This bug has been marked as a duplicate of bug 496529 ***

Note You need to log in before you can comment on or make changes to this bug.