Bug 501341 - low informative anaconda message
low informative anaconda message
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 12:08 EDT by Alexey Kuznetsov
Modified: 2009-06-10 09:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 09:32:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
1) custom layout (101.90 KB, image/jpeg)
2009-05-18 13:38 EDT, Alexey Kuznetsov
no flags Details
2) partiting (77.51 KB, image/jpeg)
2009-05-18 13:39 EDT, Alexey Kuznetsov
no flags Details
3) set root on sda3 (81.01 KB, image/jpeg)
2009-05-18 13:39 EDT, Alexey Kuznetsov
no flags Details
4) press finish (we have noting to do). error! (80.30 KB, image/jpeg)
2009-05-18 13:40 EDT, Alexey Kuznetsov
no flags Details
5) setting sda1 to /boot/efi (79.22 KB, image/jpeg)
2009-05-18 13:40 EDT, Alexey Kuznetsov
no flags Details
6) done. skip swap (100.38 KB, image/jpeg)
2009-05-18 13:41 EDT, Alexey Kuznetsov
no flags Details
Screenshot of Fedora 11-Preview installation on host dhcppc5.png (32.38 KB, image/png)
2009-05-22 10:13 EDT, Alexey Kuznetsov
no flags Details

  None (edit)
Description Alexey Kuznetsov 2009-05-18 12:08:15 EDT
I tried to install fedora live cd on my macbook pro.

On 'partitions screen' anaconda installer ask me to create efi partition, but it already exists. Anaconda installer dialog showed "Please create EFI System Partion". Which i understand as recreating already existing worked efi partition.

Indeed anaconda looking for /boot/efi labeled partition, but it not correctly described in this dialog.
Comment 1 Chris Lumens 2009-05-18 13:16:06 EDT
There have been significant changes to the storage code in anaconda since F10 was released.  Can you please test with a more recent release and if you are still seeing a problem, post exactly what you are seeing?  Something like a screenshot would be very helpful.  Thanks.
Comment 2 Alexey Kuznetsov 2009-05-18 13:27:45 EDT
i cant test last f11-live, because its hungs at boot (bug 501349). screenshots comming...
Comment 3 Alexey Kuznetsov 2009-05-18 13:38:57 EDT
Created attachment 344488 [details]
1) custom layout
Comment 4 Alexey Kuznetsov 2009-05-18 13:39:22 EDT
Created attachment 344489 [details]
2) partiting
Comment 5 Alexey Kuznetsov 2009-05-18 13:39:52 EDT
Created attachment 344490 [details]
3) set root on sda3
Comment 6 Alexey Kuznetsov 2009-05-18 13:40:26 EDT
Created attachment 344491 [details]
4) press finish (we have noting to do). error!
Comment 7 Alexey Kuznetsov 2009-05-18 13:40:52 EDT
Created attachment 344492 [details]
5) setting sda1 to /boot/efi
Comment 8 Alexey Kuznetsov 2009-05-18 13:41:15 EDT
Created attachment 344493 [details]
6) done. skip swap
Comment 9 Alexey Kuznetsov 2009-05-22 10:13:32 EDT
Created attachment 345095 [details]
Screenshot of Fedora 11-Preview installation on host dhcppc5.png

Last anconda how mutch less informative message:

it say: "you dont have BOOT partition", instead "EFI BOOT".

Please fix!!
Comment 10 Chris Lumens 2009-06-09 12:44:35 EDT
Your first several screenshots are all from the text interface, but the last screenshot is from the graphical interface.  Please attach a screenshot from the graphical interface that shows your partition layout before getting the error about not having a boot partition.  Thanks.
Comment 11 Alexey Kuznetsov 2009-06-09 13:15:59 EDT
its same layout as on 00005.jpg.
Comment 12 Alexey Kuznetsov 2009-06-09 13:17:20 EDT
* 00005.jpg - step 3)
Comment 13 Chris Lumens 2009-06-10 09:32:35 EDT
This will be fixed in the next build of anaconda.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.