Bug 501345 - grub-efi hang after selecting kernel
grub-efi hang after selecting kernel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 12:25 EDT by Alexey Kuznetsov
Modified: 2011-06-27 10:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 10:12:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
00001.jpg (77.20 KB, image/jpeg)
2009-05-18 12:43 EDT, Alexey Kuznetsov
no flags Details
00006.jpg (71.30 KB, image/jpeg)
2009-05-18 12:43 EDT, Alexey Kuznetsov
no flags Details
00005.jpg (70.91 KB, image/jpeg)
2009-05-18 12:44 EDT, Alexey Kuznetsov
no flags Details
my own grub2 build (svn lastupdates, nopaches) (69.67 KB, image/jpeg)
2009-05-18 12:44 EDT, Alexey Kuznetsov
no flags Details
grub2-ums-xlog (20.04 KB, text/plain)
2010-03-11 14:20 EST, Alexey Kuznetsov
no flags Details
grub2-ums-dmesg (43.79 KB, text/plain)
2010-03-11 14:20 EST, Alexey Kuznetsov
no flags Details

  None (edit)
Description Alexey Kuznetsov 2009-05-18 12:25:40 EDT
On my system (macbook pro 2,2) i tried to install fedora-10-live to my harddrive.

After reboot grub menu shown correctly. Also i can see counting timeout 5, but after it done grub got hunged.

I tried to set boot params, like: kernel/root or kernel params - noting help.

Last grub2 from gnu.org works fine.
Comment 1 Alexey Kuznetsov 2009-05-18 12:43:12 EDT
Created attachment 344475 [details]
00001.jpg
Comment 2 Alexey Kuznetsov 2009-05-18 12:43:36 EDT
Created attachment 344476 [details]
00006.jpg
Comment 3 Alexey Kuznetsov 2009-05-18 12:44:00 EDT
Created attachment 344477 [details]
00005.jpg
Comment 4 Alexey Kuznetsov 2009-05-18 12:44:47 EDT
Created attachment 344478 [details]
my own grub2 build (svn lastupdates, nopaches)

gnu.org grub works fine
Comment 5 Alexey Kuznetsov 2009-06-09 10:22:50 EDT
it isnt grub bug, look like its kernel bug.

without nomodeset kernel flag grub goes to show green fading to white screen. with nomodeset i see previous (grub) screen.
Comment 6 Alexey Kuznetsov 2009-11-10 16:16:59 EST
f12 kernel/grub the same issues. exept no more green screen death, check bug 501349
Comment 7 Alexey Kuznetsov 2010-03-11 07:23:25 EST
back to this bug.

i tried same steps for f13 and got the same results.

1. livecd-iso-to-disk /F13-Alpha-i686-Live.iso /dev/sdb1
2. copy F13-Alpha-i686-Live.iso/EFI folder to /dev/sdb1
3. boot
4. grub shows
5. select kernel and boots continue
6. you can hear speakers tick, but grub screen shows
7. you can see loading finished and seems like you see login screen
8. still grub's splash screen.

i think kernel-ati driver unable to reset efi screen. or switch some internal buffers to it self.
Comment 8 Alexey Kuznetsov 2010-03-11 14:19:44 EST
i can boot my macbook pro with grub2.

for KMS mode i got corrupted screen.
for UMS mode i unable to start Xserver. its crash with V_BIOS error.  

--

summary macbook efi fails:
 - grub1
    - all modes unable to switch back from grub screen
 - grub2
    - KMS mode currpted screen
    - UMS mode X-crash V_BIOS
Comment 9 Alexey Kuznetsov 2010-03-11 14:20:18 EST
Created attachment 399422 [details]
grub2-ums-xlog
Comment 10 Alexey Kuznetsov 2010-03-11 14:20:39 EST
Created attachment 399423 [details]
grub2-ums-dmesg
Comment 11 Bug Zapper 2011-06-02 14:05:10 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2011-06-27 10:12:16 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.