Bug 501361 - SELinux is preventing hal-storage-mount (hald_t) "getattr" to Fedora-10-i386-DVD.iso (public_content_t)
SELinux is preventing hal-storage-mount (hald_t) "getattr" to Fedora-10-i386-...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 14:05 EDT by Cristian Ciupitu
Modified: 2010-01-08 08:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-19 11:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cristian Ciupitu 2009-05-18 14:05:30 EDT
Description of problem:
My system is loop mounting some ISO files using /etc/fstab and I'm getting SELinux denials from hal-storage-mount.

Version-Release number of selected component (if applicable):
selinux-policy-3.5.13-58.fc10.noarch.rpm
selinux-policy-targeted-3.5.13-58.fc10.noarch.rpm

How reproducible:
Every time.

Steps to Reproduce:
1. Loop mount an ISO file marked as public_content_t using /etc/fstab:
/mnt/newBACKUP/Software/Linux/Fedora/Fedora-10-i386-DVD/Fedora-10-i386-DVD.iso  /mnt/misc/Fedora-10-i386-DVD  iso9660  loop,ro  0 0
2. (Re)Boot the system
  
Actual results:
SELinux denial errors:
node=hermes.lizeanunet.tld type=AVC msg=audit(1242667555.104:16): avc: denied { getattr } for pid=2765 comm="hal-storage-mou" path="/mnt/newBACKUP/Software/Linux/Fedora/Fedora-10-i386-DVD/Fedora-10-i386-DVD.iso" dev=sdc3 ino=573907783 scontext=system_u:system_r:hald_t:s0 tcontext=unconfined_u:object_r:public_content_t:s0 tclass=file
node=hermes.lizeanunet.tld type=SYSCALL msg=audit(1242667555.104:16): ch=40000003 syscall=196 success=no exit=-13 a0=8c817f0 a1=bfca46dc a2=4d2ff4 a3=2 items=0 ppid=2173 pid=2765 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="hal-storage-mou" exe="/usr/libexec/hal-storage-mount

Expected results:
There shouldn't be any SELinux denial errors, because I'm not doing anything special.

Additional info:
I'm using the following packages:
libselinux-2.0.78-1.fc10.i386.rpm
hal-0.5.12-14.20081027git.fc10.i386.rpm
hal-info-20090202-1.fc10.noarch.rpm
hal-libs-0.5.12-14.20081027git.fc10.i386.rpm
Comment 1 Daniel Walsh 2009-05-18 14:35:30 EDT
Miroslav add

files_getattr_all_files(hald_t)

to hal.te
Comment 2 Miroslav Grepl 2009-05-22 05:55:11 EDT
Fixed in selinux-policy-3.5.13-61.fc10
Comment 3 Miroslav Grepl 2009-08-19 11:38:16 EDT
Closing all bugs that have been in modified for over a month.  Please reopen if
the bug is not actually fixed.
Comment 4 Cristian Ciupitu 2009-08-19 14:29:59 EDT
(In reply to comment #3)
> Closing all bugs that have been in modified for over a month.  Please reopen if
> the bug is not actually fixed.  

I have migrated to Fedora 11 since then, but I haven't had any problems anymore. I'm currently using selinux-policy-3.6.12-72.fc11.noarch.rpm and selinux-policy-targeted-3.6.12-72.fc11.noarch.rpm.

Note You need to log in before you can comment on or make changes to this bug.