Bug 501369 - Some applications do not have sound because there is no /dev/dsp
Some applications do not have sound because there is no /dev/dsp
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 15:23 EDT by Eddie Lania
Modified: 2009-05-18 17:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 17:23:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddie Lania 2009-05-18 15:23:38 EDT
Description of problem: Some applications do not have sound because there is no /dev/dsp.

For instance PySOL:
pysol
/usr/lib/python2.6/site-packages/pysollib/init.py:156: DeprecationWarning: os.popen3 is deprecated.  Use the subprocess module.
  pin, pout, perr = os.popen3(settings.FCS_COMMAND+' --help')
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pysollib/pysolaudio.py", line 349, in playLoop
    audiodev = ossaudiodev.open('w')
IOError: [Errno 2] No such file or directory: '/dev/dsp'

I can launch "MAKEDEV /dev/dsp" and enable /dev/dsp, but after a reboot it is removed again.



Version-Release number of selected component (if applicable):

PySolFC-1.1-8.fc11.noarch
pulseaudio-libs-zeroconf-0.9.15-11.fc11.i586
wine-pulseaudio-1.1.18-1.fc11.i586
alsa-plugins-pulseaudio-1.0.18-3.fc11.i586
pulseaudio-0.9.15-11.fc11.i586
pulseaudio-module-zeroconf-0.9.15-11.fc11.i586
pulseaudio-module-x11-0.9.15-11.fc11.i586
pulseaudio-module-bluetooth-0.9.15-11.fc11.i586
pulseaudio-module-gconf-0.9.15-11.fc11.i586
projectM-pulseaudio-1.2.0-4.fc11.i586
pulseaudio-utils-0.9.15-11.fc11.i586
xine-lib-pulseaudio-1.1.16.3-2.fc11.i586
pulseaudio-esound-compat-0.9.15-11.fc11.i586
pulseaudio-libs-glib2-0.9.15-11.fc11.i586
pulseaudio-libs-0.9.15-11.fc11.i586
pulseaudio-module-jack-0.9.15-11.fc11.i586


How reproducible: Allways.


Steps to Reproduce:
1.Instal PySOL
2.Launch it and make sure sound is enabled in pysol's options
3.Launch it again from a command prompt in a terminal, there is no sound and a message like above is being generated.
  
Actual results: No sound because no /dev/dsp


Expected results: Sound working


Additional info:
Comment 1 Lennart Poettering 2009-05-18 17:23:04 EDT
This has nothing to do with PulseAudio.

For F11 we decided to disable the OSS API since it is has been obsolete since quite some time.

Please port your application to ALSA!

Dirty hacks to make those apps work without porting are using "padsp" or reenabling those kernel modules by patching around in the modprobe configuration.

Note You need to log in before you can comment on or make changes to this bug.