Bug 501399 - Can't install i586 and x86_64 packages on the same machine
Can't install i586 and x86_64 packages on the same machine
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libgnome (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 18:08 EDT by Kevin DeKorte
Modified: 2009-06-12 12:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 21:54:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin DeKorte 2009-05-18 18:08:12 EDT
Description of problem:
Should be able to install .i586 and .x86_64 libs on the same machine

Version-Release number of selected component (if applicable):
2.26.0-1

How reproducible:
100%

Steps to Reproduce:
1. yum install libgnome.i586 libgnome.x86_64
2.
3.
  
Actual results:
file /etc/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_accessibility_startup.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_applications_at_mobility.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_applications_at_visual.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_applications_browser.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_applications_office.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_applications_terminal.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_applications_window_manager.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_background.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_file_views.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_interface.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_lockdown.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_peripherals_mouse.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_sound.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_thumbnail_cache.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_thumbnailers.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/gconf/schemas/desktop_gnome_typing_break.schemas from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/sound/events/gnome-2.soundlist from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /etc/sound/events/gtk-events-2.soundlist from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/as/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/bg/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/bn_IN/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/ca/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/cs/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/da/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/de/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/el/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/en_GB/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/es/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/et/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/eu/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/fi/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/fr/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/gl/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/gu/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/he/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/hi/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/hu/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/it/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/ja/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/ko/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/lt/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/lv/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/ml/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/mr/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/nb/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/nl/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/or/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/pa/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/pl/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/pt/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/pt_BR/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/ro/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/ru/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/sl/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/sv/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/ta/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/te/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/th/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/tr/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/uk/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/vi/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/zh_HK/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64
  file /usr/share/locale/zh_TW/LC_MESSAGES/libgnome-2.0.mo from install of libgnome-2.26.0-1.fc11.i586 conflicts with file from package libgnome-2.24.1-10.fc11.x86_64


Expected results:
Packages should install

Additional info:
Comment 1 Bug Zapper 2009-06-09 12:05:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matthias Clasen 2009-06-11 21:54:02 EDT
These are different versions of libgnome that you have there. 

multilib only has a chance of working for the exact same version in two different arches.
Comment 3 Kevin DeKorte 2009-06-12 12:36:40 EDT
Must have been an out of sync repository then, seems to be fine now.

Note You need to log in before you can comment on or make changes to this bug.