Bug 50142 - output and input redirect fails
Summary: output and input redirect fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-27 07:31 UTC by johan
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-27 07:32:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description johan 2001-07-27 07:31:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 4.01; Windows 98)

Description of problem:
When I redirect input and ouput in a bash shell to communicate with a 
modem on ttySx the output goes to stdout. 

It did work in RH5.1 but since upgrading to RH 7.0 it no longer works.

When using bash from the RH 5.1 distribution in an RH 7.0 environment the 
problem does not occur.

How reproducible:
Always

Steps to Reproduce:
1. Create a bash script such as;
_____________________
#!/bin/bash

chat -t 30 '' ATZ OK '' <> /dev/ttyS0
_____________________

2. Execute the scrpit

3. The output will be something like;
# ./"script_name"
ATZ

^C
4. Notice that the output from the chat command came to stdout instead of 
/dev/ttyS0


Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-01-17 21:17:54 UTC
This is true, but it's not a bug.
The new behavior is the one required by the POSIX standard (which bash >= 2.0 is following).




Note You need to log in before you can comment on or make changes to this bug.