Bug 501443 - RFE: anaconda: split region / timezone selection into multiple menus
RFE: anaconda: split region / timezone selection into multiple menus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 03:57 EDT by Stefan Assmann
Modified: 2014-03-17 07:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-17 07:42:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
current dialog (123.00 KB, image/png)
2009-05-19 03:57 EDT, Stefan Assmann
no flags Details
example dialog (31.40 KB, image/png)
2009-05-19 03:58 EDT, Stefan Assmann
no flags Details

  None (edit)
Description Stefan Assmann 2009-05-19 03:57:03 EDT
Created attachment 344584 [details]
current dialog

Description of problem:

Currently in ananconda there's one big menu to select the region and timezone you're located in, resulting in a huge list of combinations. This could be split up to into 2 different menus, one to select the region and another for the actual location/timezone. By doing this we avoid having to scroll through such a huge list.

Screenshots of what it currently looks like and what it could look like as an example will be attached.
Comment 1 Stefan Assmann 2009-05-19 03:58:29 EDT
Created attachment 344585 [details]
example dialog
Comment 2 Chris Lumens 2009-05-19 09:59:10 EDT
We try to follow what system-config-date does as closely as possible here, and I don't believe it does anything like this right now.  We could probably break the timezone information up into regions based on the slashes, though if we're going to do something like this, I'd really like s-c-date to take the initiative and then we use what they do.

In addition, I'd really like to rework all the region selection stuff in anaconda overall.
Comment 3 Jaromír Končický 2014-03-17 07:42:53 EDT
In current Fedoras (F19, F20) it is already changed so you don't need to browse an insanely long list. It is split into Region and City menu so your request is fulfiled. Finally closing after years :)

Note You need to log in before you can comment on or make changes to this bug.