Bug 501521 - Clone software channel success/failure message doesn't appear on destination page
Clone software channel success/failure message doesn't appear on destination ...
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-05-19 11:05 EDT by Jay Dobies
Modified: 2014-07-04 09:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2009-05-19 11:05:27 EDT
Description of problem:
This is very similar to 500719.

When the manage software channels page was ported to Java, we run into an issue where the perl pages stuff a message into its session and the Java page cannot access it.

After some discussion, the easiest way to address this is to simply port the page to Java. It's going to happen eventually, and the crossover solutions for passing the message between stacks are ugly.

Version-Release number of selected component (if applicable):
Satellite 5.3 Beta

How reproducible:
Always

Steps to Reproduce:
1. Clone a software channel.
  
Actual results:
Redirected to the manage software channels page but no message is displayed. The message is eventually displayed the next time a perl page is hit.

Expected results:
The result message should be displayed on the resulting page from the clone rather than randomly later the next time a perl page is hit.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.