Bug 50160 - missing requirement in rpm package
Summary: missing requirement in rpm package
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-27 14:31 UTC by Roel van Meer
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-27 14:31:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roel van Meer 2001-07-27 14:31:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.18 i686)

Description of problem:
the binutils rpm uses /sbin/install-info in its postinstall script, but has
no dependancy on info, which provides /sbin/install-info.
When installing a custom system with anaconda, chances are that binutils
gets installed _before_ info does, so the postinstall script will fail.

How reproducible:
Always

Steps to Reproduce:
1. install a custom system with anaconda
2. see output from /tmp/install.log below
3.
	

Actual Results:  Installing binutils.
/var/tmp/rpm-tmp.71027: /sbin/install-info: No such file or directory
/var/tmp/rpm-tmp.71027: /sbin/install-info: No such file or directory
/var/tmp/rpm-tmp.71027: /sbin/install-info: No such file or directory
/var/tmp/rpm-tmp.71027: /sbin/install-info: No such file or directory
/var/tmp/rpm-tmp.71027: /sbin/install-info: No such file or directory
/var/tmp/rpm-tmp.71027: /sbin/install-info: No such file or directory
/var/tmp/rpm-tmp.71027: /sbin/install-info: No such file or directory
execution of %post scriptlet from binutils-2.9.5.0.22-6 failed, exit status
126



Expected Results:  anaconda should have installed info before binutils

Additional info:

Chances are that in other systems info does get installed before binutils
due to some other requirement.

Comment 1 Jakub Jelinek 2001-08-03 17:07:17 UTC
This was fixed in binutils that are in 7.1 distribution and up.
I don't think it is severe enough to require errata for 6.2.


Note You need to log in before you can comment on or make changes to this bug.