Bug 501643 - firefox crashes with seg fault on rawhide
firefox crashes with seg fault on rawhide
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 02:33 EDT by Kashyap Chamarthy
Modified: 2009-07-14 02:17 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 02:17:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of firefox seg fault on rawhide (38.55 KB, text/plain)
2009-05-20 02:34 EDT, Kashyap Chamarthy
no flags Details

  None (edit)
Description Kashyap Chamarthy 2009-05-20 02:33:27 EDT
Description of problem:
firefox crashes often on rawhide with segfault when tried to scroll a website.

/usr/lib/firefox-3.5b4/run-mozilla.sh: line 131:  5977 Segmentation fault      "$prog" ${1+"$@"}
Comment 1 Kashyap Chamarthy 2009-05-20 02:34:50 EDT
Created attachment 344746 [details]
strace of firefox seg fault on rawhide

strace output of firefox crash on rawhide(x86)
Comment 2 Rahul Sundaram 2009-05-20 02:41:23 EDT
I can reproduce this by visiting fedoraforum.org and logging in as well. So not limited to one website.
Comment 3 kushaldas@gmail.com 2009-05-20 02:44:51 EDT
Same happens for planet.fedoraproject.org
Comment 4 Martin Stransky 2009-05-20 04:41:13 EDT
Can you attach gdb bactrace?
Comment 5 Yanko Kaneti 2009-05-20 05:17:16 EDT
Most likely bug 501632
Comment 6 Kashyap Chamarthy 2009-05-20 05:51:33 EDT
I tried reproducing the issue, while running firefox in gdb ...only waited eternity to hit a backtrace......it never crashes :(
Comment 7 Martin Stransky 2009-05-20 06:01:04 EDT
Without the backtrace we can't continue to work on this bug.
Comment 8 Kashyap Chamarthy 2009-05-20 06:33:54 EDT
yes, I do understand.Now it works fine for me too. I tried several times, but it was kind of erratic behaviour.
Perhaps, can this be closed as works-for-me or not-a-bug??. If anybody else experiences the same problem consistently, let them come back with backtrace and then proceed.
Comment 9 Adam Williamson 2009-05-20 16:37:21 EDT
no-one seems able to reproduce this now, so closing as CANTFIX (since it was definitely a valid issue reproduced by several people, but it's impossible to provide the necessary info to fix it now). it can be re-opened if encountered again, but as it's rather hard to know if it's the same bug, probably best to pen a new report. And make sure to include a backtrace :)
Comment 10 Rahul Sundaram 2009-05-21 03:18:26 EDT
I can reproduce this by just visiting fedoraforum.org. /usr/bin/firefox is a shell script which you can't run gdb against. Where is the binary located?
Comment 11 Martin Stransky 2009-05-21 03:29:56 EDT
run firefox -g -d gdb
Comment 12 Bug Zapper 2009-06-09 12:08:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Yanko Kaneti 2009-06-30 19:01:07 EDT
Can anyone still reproduce this or should we just INCOMPLETE it. Rahul?
Comment 14 Jeff Karpinski 2009-07-07 10:33:43 EDT
Here's the gdb output. Could possibly be java related as it's relatively reproducible when using java-based sites.

[jkarp@tyrell Desktop]$ firefox -g -d gdb
MOZILLA_FIVE_HOME=/usr/lib/firefox-3.5
  LD_LIBRARY_PATH=/usr/lib/firefox-3.5:/usr/lib/firefox-3.5/plugins:/usr/lib/firefox-3.5
DISPLAY=:0.0
FONTCONFIG_PATH=/etc/fonts:/usr/lib/firefox-3.5/res/Xft
DYLD_LIBRARY_PATH=/usr/lib/firefox-3.5:/usr/lib/firefox-3.5
     LIBRARY_PATH=/usr/lib/firefox-3.5:/usr/lib/firefox-3.5/components:/usr/lib/firefox-3.5
       SHLIB_PATH=/usr/lib/firefox-3.5:/usr/lib/firefox-3.5
          LIBPATH=/usr/lib/firefox-3.5:/usr/lib/firefox-3.5
       ADDON_PATH=/usr/lib/firefox-3.5
      MOZ_PROGRAM=/usr/lib/firefox-3.5/firefox
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=gdb
/usr/bin/gdb /usr/lib/firefox-3.5/firefox -x /tmp/mozargs.lAi09x
GNU gdb (GDB) Fedora (6.8.50.20090302-32.fc11)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i586-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
(gdb) run
Starting program: /usr/lib/firefox-3.5/firefox 
warning: .dynamic section for "/lib/libm.so.6" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
[Thread debugging using libthread_db enabled]
warning: .dynamic section for "/usr/lib/libbonobo-2.so.0" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
warning: .dynamic section for "/usr/lib/libavahi-glib.so.1" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
[New Thread 0xb77ffb70 (LWP 3040)]
[New Thread 0xb6dfeb70 (LWP 3041)]
[New Thread 0xb60ffb70 (LWP 3042)]
[New Thread 0xb52ffb70 (LWP 3043)]
[New Thread 0xb3dffb70 (LWP 3044)]
[Thread 0xb52ffb70 (LWP 3043) exited]
[New Thread 0xb52ffb70 (LWP 3045)]
[New Thread 0xb1cffb70 (LWP 3046)]
[New Thread 0xb12feb70 (LWP 3047)]
[New Thread 0xb08fdb70 (LWP 3048)]
[New Thread 0xafefcb70 (LWP 3049)]
[New Thread 0xaf4fbb70 (LWP 3050)]
[New Thread 0xae7ffb70 (LWP 3051)]
[New Thread 0xaddfeb70 (LWP 3052)]
Detaching after fork from child process 3053.
[New Thread 0xad3fdb70 (LWP 3054)]
[New Thread 0xac6ffb70 (LWP 3066)]
[Thread 0xac6ffb70 (LWP 3066) exited]
[New Thread 0xac6ffb70 (LWP 3068)]
warning: .dynamic section for "/lib/libacl.so.1" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
[Thread 0xac6ffb70 (LWP 3068) exited]

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xb4690790)
[New Thread 0xac6ffb70 (LWP 3078)]
[New Thread 0xb488db70 (LWP 3085)]
[New Thread 0xab6ffb70 (LWP 3086)]
[New Thread 0xaacfeb70 (LWP 3087)]
[Thread 0xac6ffb70 (LWP 3078) exited]
[Thread 0xab6ffb70 (LWP 3086) exited]
[Thread 0xaacfeb70 (LWP 3087) exited]
[New Thread 0xaa2fdb70 (LWP 3088)]
[New Thread 0xa96ffb70 (LWP 3089)]
[New Thread 0xa8cfeb70 (LWP 3090)]
[Thread 0xaa2fdb70 (LWP 3088) exited]
[Thread 0xa96ffb70 (LWP 3089) exited]
[Thread 0xa8cfeb70 (LWP 3090) exited]
[New Thread 0xaa2fdb70 (LWP 3091)]
[Thread 0xaa2fdb70 (LWP 3091) exited]
[New Thread 0xaa2fdb70 (LWP 3092)]
[New Thread 0xa96ffb70 (LWP 3093)]
[New Thread 0xa8cfeb70 (LWP 3094)]
[Thread 0xa96ffb70 (LWP 3093) exited]
[Thread 0xa8cfeb70 (LWP 3094) exited]
[New Thread 0xab6ffb70 (LWP 3095)]
[New Thread 0xa96ffb70 (LWP 3096)]
[New Thread 0xa8cfeb70 (LWP 3097)]
[Thread 0xab6ffb70 (LWP 3095) exited]
[Thread 0xa96ffb70 (LWP 3096) exited]
[Thread 0xa8cfeb70 (LWP 3097) exited]
[New Thread 0xab6ffb70 (LWP 3098)]
[New Thread 0xa96ffb70 (LWP 3099)]
[Thread 0xa96ffb70 (LWP 3099) exited]
[Thread 0xb12feb70 (LWP 3047) exited]
[New Thread 0xb12feb70 (LWP 3100)]
[Thread 0xb12feb70 (LWP 3100) exited]
[New Thread 0xb12feb70 (LWP 3101)]
[Thread 0xb12feb70 (LWP 3101) exited]
[New Thread 0xb12feb70 (LWP 3102)]
[Thread 0xb12feb70 (LWP 3102) exited]
[New Thread 0xb12feb70 (LWP 3103)]
[Thread 0xb12feb70 (LWP 3103) exited]
Detaching after fork from child process 3104.
Detaching after fork from child process 3114.

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xac5c79f0)

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xaabef6e0)

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xac20f5d0)

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xac210600)

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xac2103d0)

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xa7f13c20)

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xabb24de0)

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xabb24fa0)

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xabb78f70)

(firefox:3037): GLib-GObject-WARNING **: IA__g_object_weak_unref: couldn't find weak ref 0xd68650(0xabb79910)

Program received signal SIGSEGV, Segmentation fault.
0x03655ebc in vtable for nsDOMEvent () from /usr/lib/xulrunner-1.9.1/libxul.so
Missing separate debuginfos, use: debuginfo-install ORBit2-2.14.17-1.fc11.i586 avahi-0.6.25-3.fc11.i586 avahi-glib-0.6.25-3.fc11.i586 dbus-glib-0.80-2.fc11.i586 dbus-libs-1.2.12-2.fc11.i586 e2fsprogs-libs-1.41.4-12.fc11.i586 expat-2.0.1-6.i586 gamin-0.1.10-4.fc11.i586 gnome-keyring-2.26.3-1.fc11.i586 gtk-nodoka-engine-0.7.2-4.fc11.i586 gvfs-1.2.3-8.fc11.i586 java-1.6.0-openjdk-plugin-1.6.0.0-22.b16.fc11.i586 keyutils-libs-1.2-5.fc11.i586 krb5-libs-1.6.3-20.fc11.i586 libICE-1.0.4-7.fc11.i586 libSM-1.1.0-4.fc11.i586 libX11-1.2.1-2.fc11.i586 libXScrnSaver-1.1.3-2.fc11.i586 libXau-1.0.4-5.fc11.i586 libXcomposite-0.4.0-7.fc11.i586 libXcursor-1.1.9-4.fc11.i586 libXdamage-1.1.1-6.fc11.i586 libXext-1.0.99.1-2.fc11.i586 libXfixes-4.0.3-5.fc11.i586 libXi-1.2.1-1.fc11.i586 libXinerama-1.0.3-4.fc11.i586 libXrandr-1.2.99.4-3.fc11.i586 libXrender-0.9.4-5.fc11.i586 libXt-1.0.5-2.fc11.i586 libacl-2.2.47-4.fc11.i586 libart_lgpl-2.3.20-4.fc11.i586 libattr-2.4.43-3.fc11.i586 libbonobo-2.24.1-1.fc11.i586 libbonoboui-2.24.1-1.fc11.i586 libcap-2.16-4.fc11.1.i586 libgnome-2.26.0-1.fc11.i586 libgnomecanvas-2.26.0-1.fc11.i586 libgnomeui-2.24.1-1.fc11.i586 libjpeg-6b-45.fc11.i586 libpng-1.2.37-1.fc11.i586 libselinux-2.0.80-1.fc11.i586 libxcb-1.2-4.fc11.i586 libxml2-2.7.3-2.fc11.i586 nss-3.12.3.99.3-2.11.3.fc11.i586 nss-softokn-freebl-3.12.3.99.3-2.11.3.fc11.i586 openssl-0.9.8k-5.fc11.i686 pixman-0.14.0-2.fc11.i586 popt-1.13-5.fc11.i586 rhythmbox-0.12.2.93-1.fc11.i586 sqlite-3.6.12-3.fc11.i586 totem-mozplugin-2.26.3-1.fc11.i586 totem-pl-parser-2.26.2-2.fc11.i586 zlib-1.2.3-22.fc11.i586
(gdb)
Comment 15 Jeff Karpinski 2009-07-08 15:52:09 EDT
Nevermind. My issue was indeed Java. Uninstalled OpenJDK and loaded a proper Sun JRE and all is right in the world. Should've thought of that in the first place. OpenJDK is utter crap. Always has been.
Comment 16 Rahul Sundaram 2009-07-09 01:07:09 EDT
OpenJDK is almost 100% the same codebase as Sun JDK and has passed Sun's own test suite as well. If you have problems with it, please report them.
Comment 17 Matěj Cepl 2009-07-13 18:35:44 EDT
Reassigning to OpenJDK component then (of course, I totally don't agree with its evaluation in comment 15).
Comment 18 Mark Wielaard 2009-07-13 19:43:56 EDT
Is there a reproducer? I tried visiting several of the URLs mentioned in the comments, but all work fine for me.
Comment 19 Rahul Sundaram 2009-07-13 19:51:00 EDT
The needinfo shouldn't be set against me. I haven't reported it.
Comment 20 Mark Wielaard 2009-07-13 20:04:20 EDT
(In reply to comment #19)
> The needinfo shouldn't be set against me. I haven't reported it.  

Sorry, I misunderstood. You posted the URLs that supposedly crashed firefox. They don't for me though. Do they still give you trouble? Is there any other way to reproduce this issue? Is the reported still interested in resolving?
Comment 21 Rahul Sundaram 2009-07-13 20:25:38 EDT
I haven't seen any problems in quite sometime. It is likely any issues I had were fixed in the beta 4 -> GA update. Not sure about the OpenJDK problem mentioned in #15. Seems unrelated.
Comment 22 Kashyap Chamarthy 2009-07-14 00:02:42 EDT
Even I haven't seen any trouble in the recent past(I'm using F11 GA in a VM though). Perhaps, as said in comment 21, it is fixed in the GA.
Comment 23 Mark Wielaard 2009-07-14 02:17:35 EDT
Thanks for the feedback. Closed for now then. Please feel free to reopen if you can reproduce.

Note You need to log in before you can comment on or make changes to this bug.