Bug 501644 - [IBus] focus-out and disabled IME should hide language panel
[IBus] focus-out and disabled IME should hide language panel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 02:50 EDT by Ding-Yi Chen
Modified: 2009-05-28 04:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.0.20090508-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 04:04:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2009-05-20 02:50:28 EDT
Description of problem:
Sometime disabled IME still have language panel.

Version-Release number of selected component (if applicable):
ibus-1.1.0.20090508-2

How reproducible:
Always


Steps to Reproduce:
0  Installed ibus-pinyin in IBus.
1. Turn the language panel to "Always on" in order to spot the problem more easily.
2. Switch on IME in IM Client A
3. Switch on IME in Client B
4. Switch off IME in Client A
5. Let Client B has focus by clicking on it.
6. Click back on A
  
Actual results:
Language panel still shows for Client A, even when IME is disable.


Expected results:
Language panel should be hidden for Client A, as IME is disable.


Additional info:
This can be fixed in either IBus side or IME side.
Comment 1 Peng Huang 2009-05-25 02:35:13 EDT
This problem has been fixed in upstream. If you have time please test it. And I will build it for fedora soon.
Comment 2 Fedora Update System 2009-05-25 05:05:01 EDT
ibus-1.1.0.20090508-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ibus-1.1.0.20090508-4.fc11
Comment 3 Ding-Yi Chen 2009-05-25 20:46:34 EDT
The issue is fixed, thanks!
Comment 4 Fedora Update System 2009-05-26 03:54:49 EDT
ibus-1.1.0.20090508-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5495
Comment 5 Fedora Update System 2009-05-26 22:02:21 EDT
ibus-1.1.0.20090508-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ibus-1.1.0.20090508-5.fc11
Comment 6 Fedora Update System 2009-05-28 04:04:43 EDT
ibus-1.1.0.20090508-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.