Bug 501675 - vgreduce is failed when multipath(EMC powerpath) device name is passed
vgreduce is failed when multipath(EMC powerpath) device name is passed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.5
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 05:30 EDT by Praveenkumar
Modified: 2011-02-24 04:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 10:09:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Praveenkumar 2009-05-20 05:30:48 EDT
Description of problem:
On RHEL5 having LVM2 of version (2.02.40-RHEL5 ), volume group "kg" is created with "vgcreate" as below 

      >pvcreate /dev/emcpowerg 
      >vgcreate "test_vg" /dev/emcpowerg

Here, EMC powerpath(multipath) device names are used to create the volume group. Volume group creation succeeds.

Then we extended the VG by passing another powerpath device name,
       >vgextend "test_vg" /dev/emcpoweri
Here also, vgextend successfully returns back after extending the VG size.

Then, if we try to delete the /dev/emcpoweri from the volume group as below then it returns with an error.
       >vgreduce "test_vg" /dev/emcpoweri
        The Device/s could not be removed from the Volume Group

/dev/emcpoweri is alternative path for device "/dev/sdj". So to "vgreduce", if "/dev/sdj" is passed instead of "/dev/emcpoweri" then command works fine and returns successfully.
       >vgreduce "test_vg" /dev/sdj
        
The same behavior is seen on RHEL5 LVM2 Version (2.02.16-RHEL5)

Whereas on RHEL4-LVM2 Version (2.02.21-RHEL4 ). vgreduce is working fine with scsi device file (/dev/sd*) and EMC  alternative path (/dev/emcpower*).

Looks like vgreduce with multipath(EMC powerpath) is failing in RHEL5 LVM2 Version (2.02.16-RHEL5) and further version.

Version-Release number of selected component (if applicable):
LVM2 2.02.16-RHEL5 onwards

How reproducible:
Everytime

Steps to Reproduce:
1.pvcreate /dev/emcpowerg 
  vgcreate "test_vg" /dev/emcpowerg
2.vgextend "test_vg" /dev/emcpoweri
3.vgreduce "test_vg" /dev/emcpoweri
  
Actual results:
The Device/s could not be removed from the Volume Group

Expected results:
Vgreduce should remove the device from the group.

Additional info:
Comment 3 Heinz Mauelshagen 2010-10-05 10:09:37 EDT
Please reopen if the bug still exists in the current release.
Comment 4 Ajai 2011-02-24 03:21:48 EST
(In reply to comment #3)
> Please reopen if the bug still exists in the current release.

The problem is still there in LVM2 2.02.46-RHEL5
Comment 5 Milan Broz 2011-02-24 04:07:43 EST
> The problem is still there in LVM2 2.02.46-RHEL5

Current RHEL5 lvm2 release is lvm2-2.02.74-5.el5_6.1

Note You need to log in before you can comment on or make changes to this bug.