Bug 501687 - Error in PREIN scriptlet in rpm package nut-client-2.4.1-4.fc12.ppc - usermod: group 'dialout' does not exist
Error in PREIN scriptlet in rpm package nut-client-2.4.1-4.fc12.ppc - usermod...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 06:43 EDT by Alan Pevec
Modified: 2009-05-21 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.4.1-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 19:25:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Pevec 2009-05-20 06:43:55 EDT
Description of problem:
from root.log of the build with BR on nut
...
DEBUG util.py:256:  usermod: group 'dialout' does not exist
DEBUG util.py:256:  Error in PREIN scriptlet in rpm package nut-client-2.4.1-4.fc12.ppc
DEBUG util.py:256:  error: %pre(nut-client-2.4.1-4.fc12.ppc) scriptlet failed, exit status 6
DEBUG util.py:256:  error:   install: %pre scriptlet failed (2), skipping nut-client-2.4.1-4.fc12


Version-Release number of selected component (if applicable):
nut-client-2.4.1-4.fc12

How reproducible:
always

Steps to Reproduce:
1. fedora-cvs collectd
2. cd collectd/devel
3. make scratch-build
  
Actual results:
BuildError: error building package (arch ppc), mock exited with status 30; see root.log for more information
          

Expected results:
build done :)
Comment 1 Alan Pevec 2009-05-20 06:45:57 EDT
it is of course not ppc specific, all arches fail the same
Comment 2 Michal Hlavinka 2009-05-20 09:57:59 EDT
dialout group should be provided by hal package, it seems it's race condition problem. If hal is installed first it would work. I'll dependency there.
Comment 3 Fedora Update System 2009-05-21 05:03:03 EDT
nut-2.4.1-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/nut-2.4.1-5.fc11
Comment 4 Fedora Update System 2009-05-21 19:24:59 EDT
nut-2.4.1-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.