Bug 501701 - IPA Server install fails on RHEL5.3 - Error: Missing Dependency: libprldap60.so is needed
IPA Server install fails on RHEL5.3 - Error: Missing Dependency: libprldap60....
Status: CLOSED NOTABUG
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
2.0
x86_64 Linux
high Severity high
: v2 release
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 08:12 EDT by Sankar Ramalingam
Modified: 2015-01-04 18:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 09:06:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sankar Ramalingam 2009-05-20 08:12:40 EDT
Description of problem:

IPA Server install(yum) fails on RHEL5.3 x86_64 machine. It says

Error: Missing Dependency: libssldap60.so is needed by package ipa-client-2.0-2.20090520.el5ipa.i386 (ipa-daily)

Complete yum output.
--------------------

[root@rhvdipa ~]# yum install ipa-server
Loaded plugins: rhnplugin, security, versionlock
Reading version lock configuration
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package ipa-server.i386 0:2.0-2.20090520.el5ipa set to be updated
--> Processing Dependency: ipa-admintools = 2.0-2.20090520.el5ipa for package: ipa-server
--> Processing Dependency: ipa-client = 2.0-2.20090520.el5ipa for package: ipa-server
--> Processing Dependency: ipa-server-selinux = 2.0-2.20090520.el5ipa for package: ipa-server
--> Processing Dependency: ipa-python = 2.0-2.20090520.el5ipa for package: ipa-server
--> Processing Dependency: krb5-server-ldap >= 1.6.1-18 for package: ipa-server
--> Processing Dependency: krb5-server >= 1.6.1-18 for package: ipa-server
--> Processing Dependency: slapi-nis >= 0.15 for package: ipa-server
--> Processing Dependency: libldap60.so for package: ipa-server
--> Processing Dependency: libprldap60.so for package: ipa-server
--> Processing Dependency: libssldap60.so for package: ipa-server
--> Processing Dependency: python-pyasn1 for package: ipa-server
--> Processing Dependency: openldap-clients for package: ipa-server
--> Processing Dependency: python-krbV for package: ipa-server
--> Processing Dependency: mod_auth_kerb for package: ipa-server
--> Processing Dependency: python-cherrypy for package: ipa-server
--> Processing Dependency: mod_python for package: ipa-server
--> Running transaction check
---> Package krb5-server-ldap.i386 0:1.6.1-26.el5ipa set to be updated
---> Package ipa-python.i386 0:2.0-2.20090520.el5ipa set to be updated
--> Processing Dependency: python-kerberos >= 1.1 for package: ipa-python
--> Processing Dependency: python-nss for package: ipa-python
---> Package python-cherrypy.noarch 0:2.2.1-9.el5ipa set to be updated
---> Package openldap-clients.x86_64 0:2.3.43-3.el5 set to be updated
---> Package mod_python.x86_64 0:3.2.8-3.1 set to be updated
---> Package slapi-nis.i386 0:0.17-1.el5ipa2 set to be updated
--> Processing Dependency: libldap60.so for package: slapi-nis
--> Processing Dependency: libprldap60.so for package: slapi-nis
--> Processing Dependency: libssldap60.so for package: slapi-nis
---> Package ipa-admintools.i386 0:2.0-2.20090520.el5ipa set to be updated
--> Processing Dependency: python-configobj for package: ipa-admintools
---> Package krb5-server.x86_64 0:1.6.1-31.el5_3.3 set to be updated
---> Package ipa-client.i386 0:2.0-2.20090520.el5ipa set to be updated
--> Processing Dependency: libldap60.so for package: ipa-client
--> Processing Dependency: libprldap60.so for package: ipa-client
--> Processing Dependency: libssldap60.so for package: ipa-client
---> Package ipa-server.i386 0:2.0-2.20090520.el5ipa set to be updated
--> Processing Dependency: libldap60.so for package: ipa-server
--> Processing Dependency: libprldap60.so for package: ipa-server
--> Processing Dependency: libssldap60.so for package: ipa-server
---> Package python-pyasn1.noarch 0:0.0.7a-4.el5ipa set to be updated
---> Package mod_auth_kerb.x86_64 0:5.1-3.el5 set to be updated
---> Package python-krbV.i386 0:1.0.13-4.el5ipa set to be updated
---> Package ipa-server-selinux.i386 0:2.0-2.20090520.el5ipa set to be updated
--> Running transaction check
---> Package python-configobj.noarch 0:4.4.0-1.el5ipa set to be updated
---> Package slapi-nis.i386 0:0.17-1.el5ipa2 set to be updated
--> Processing Dependency: libldap60.so for package: slapi-nis
--> Processing Dependency: libprldap60.so for package: slapi-nis
--> Processing Dependency: libssldap60.so for package: slapi-nis
---> Package python-nss.i386 0:0.1-3.el5ipa2 set to be updated
---> Package ipa-client.i386 0:2.0-2.20090520.el5ipa set to be updated
--> Processing Dependency: libldap60.so for package: ipa-client
--> Processing Dependency: libprldap60.so for package: ipa-client
--> Processing Dependency: libssldap60.so for package: ipa-client
---> Package ipa-server.i386 0:2.0-2.20090520.el5ipa set to be updated
--> Processing Dependency: libldap60.so for package: ipa-server
--> Processing Dependency: libprldap60.so for package: ipa-server
--> Processing Dependency: libssldap60.so for package: ipa-server
---> Package python-kerberos.i386 0:1.1-1.el5ipa2 set to be updated
--> Processing Conflict: ipa-server conflicts mod_ssl
--> Finished Dependency Resolution
ipa-server-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libprldap60.so is needed by package ipa-server-2.0-2.20090520.el5ipa.i386 (ipa-daily)
slapi-nis-0.17-1.el5ipa2.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libprldap60.so is needed by package slapi-nis-0.17-1.el5ipa2.i386 (ipa-daily)
ipa-server-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libldap60.so is needed by package ipa-server-2.0-2.20090520.el5ipa.i386 (ipa-daily)
slapi-nis-0.17-1.el5ipa2.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libssldap60.so is needed by package slapi-nis-0.17-1.el5ipa2.i386 (ipa-daily)
ipa-server-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> ipa-server conflicts with mod_ssl
ipa-client-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libldap60.so is needed by package ipa-client-2.0-2.20090520.el5ipa.i386 (ipa-daily)
ipa-server-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libldap60.so is needed by package ipa-server-2.0-2.20090520.el5ipa.i386 (ipa-daily)
slapi-nis-0.17-1.el5ipa2.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libldap60.so is needed by package slapi-nis-0.17-1.el5ipa2.i386 (ipa-daily)
ipa-server-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libssldap60.so is needed by package ipa-server-2.0-2.20090520.el5ipa.i386 (ipa-daily)
ipa-client-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libssldap60.so is needed by package ipa-client-2.0-2.20090520.el5ipa.i386 (ipa-daily)
ipa-server-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libprldap60.so is needed by package ipa-server-2.0-2.20090520.el5ipa.i386 (ipa-daily)
ipa-client-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libprldap60.so is needed by package ipa-client-2.0-2.20090520.el5ipa.i386 (ipa-daily)
ipa-server-2.0-2.20090520.el5ipa.i386 from ipa-daily has depsolving problems
  --> Missing Dependency: libssldap60.so is needed by package ipa-server-2.0-2.20090520.el5ipa.i386 (ipa-daily)
Error: Missing Dependency: libssldap60.so is needed by package ipa-client-2.0-2.20090520.el5ipa.i386 (ipa-daily)
Error: Missing Dependency: libldap60.so is needed by package slapi-nis-0.17-1.el5ipa2.i386 (ipa-daily)
Error: Missing Dependency: libprldap60.so is needed by package slapi-nis-0.17-1.el5ipa2.i386 (ipa-daily)
Error: Missing Dependency: libssldap60.so is needed by package slapi-nis-0.17-1.el5ipa2.i386 (ipa-daily)
Error: Missing Dependency: libldap60.so is needed by package ipa-server-2.0-2.20090520.el5ipa.i386 (ipa-daily)
Error: ipa-server conflicts with mod_ssl
Error: Missing Dependency: libldap60.so is needed by package ipa-client-2.0-2.20090520.el5ipa.i386 (ipa-daily)
Error: Missing Dependency: libprldap60.so is needed by package ipa-server-2.0-2.20090520.el5ipa.i386 (ipa-daily)
Error: Missing Dependency: libssldap60.so is needed by package ipa-server-2.0-2.20090520.el5ipa.i386 (ipa-daily)
Error: Missing Dependency: libprldap60.so is needed by package ipa-client-2.0-2.20090520.el5ipa.i386 (ipa-daily)


Additional info:

These files are already present in the system.

[root@rhvdipa ~]# locate libssldap60.so
/usr/lib64/libssldap60.so
[root@rhvdipa ~]# locate libprldap60.so
/usr/lib64/libprldap60.so
[root@rhvdipa ~]# locate libldap60.so
/usr/lib64/libldap60.so

Note You need to log in before you can comment on or make changes to this bug.