This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 501733 - lvm snapshot segment monitoring function failed.
lvm snapshot segment monitoring function failed.
Status: CLOSED DUPLICATE of bug 541357
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 10:35 EDT by Ian Donaldson
Modified: 2012-12-07 10:44 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 11:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Donaldson 2009-05-20 10:35:03 EDT
Description of problem:

Attempting to backup the root file system using lvm snapshots
gives the following errors.

---
ROOTFSDEV=/dev/VolGroup00/LogVol00
SNAPNAME=LogVol00-snap
SNAPDEV=/dev/VolGroup00/$SNAPNAME
lvcreate -l 100%FREE -s -n $SNAPNAME $ROOTFSDEV

 Unable to read from event server.
  VolGroup00-LogVol00--snap: event registration failed: Input/output error
  VolGroup00/snapshot0: snapshot segment monitoring function failed.
  Logical volume "LogVol00-snap" created
---

However the snapshot seems to be created ok and dump/fsck works on it.


Inspection of kernel messages reveals

May 20 23:58:33 HOST kernel: dmeventd[27885]: segfault at 0000000000000090 rip 00000035af20b680 rsp 00000000410730c8 error 4
May 21 00:07:59 HOST kernel: dmeventd[28187]: segfault at 0000000000000090 rip 00000035af20b680 rsp 000000004029c0c8 error 4




Version-Release number of selected component (if applicable):

# uname -a
Linux HOST 2.6.18-128.1.10.el5xen #1 SMP Wed Apr 29 14:24:51 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

# cat /etc/issue
Red Hat Enterprise Linux Server release 5.3 (Tikanga)
Kernel \r on an \m


# ls /lib*/libdevmapper-event-lvm2snapshot.so
/lib64/libdevmapper-event-lvm2snapshot.so

# file /lib*/libdevmapper-event-lvm2snapshot.so
/lib64/libdevmapper-event-lvm2snapshot.so: symbolic link to `libdevmapper-event-lvm2snapshot.so.2.02'

# file /lib64/libdevmapper-event-lvm2snapshot.so.2.02
/lib64/libdevmapper-event-lvm2snapshot.so.2.02: ELF 64-bit LSB shared object, AMD x86-64, version 1 (SYSV), stripped


# rpm -qa |grep mapper
device-mapper-multipath-0.4.7-23.el5_3.4
device-mapper-event-1.02.28-2.el5
device-mapper-1.02.28-2.el5

# rpm -qa |grep lvm
system-config-lvm-1.1.5-1.0.el5
lvm2-2.02.40-6.el5

# yum update
Loaded plugins: rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
No Packages marked for Update


prior to snapshot lvcreate...

# vgdisplay
  --- Volume group ---
  VG Name               VolGroup00
  System ID             
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  4
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                2
  Open LV               2
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               136.50 GB
  PE Size               32.00 MB
  Total PE              4368
  Alloc PE / Size       4286 / 133.94 GB
  Free  PE / Size       82 / 2.56 GB
  VG UUID               tcdD4f-OUCJ-Ll40-ddOw-Cvy3-6yGN-9SJ0W1

after snapshot lvcreate... and during dump of it...

# vgdisplay
  --- Volume group ---
  VG Name               VolGroup00
  System ID             
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  9
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                3
  Open LV               2
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               136.50 GB
  PE Size               32.00 MB
  Total PE              4368
  Alloc PE / Size       4368 / 136.50 GB
  Free  PE / Size       0 / 0   
  VG UUID               tcdD4f-OUCJ-Ll40-ddOw-Cvy3-6yGN-9SJ0W1


How reproducible:

100%


Steps to Reproduce:

see above
  
Actual results:

seee above


Expected results:

no error msg


Additional info:
Comment 2 Corey Marthaler 2010-02-17 17:36:01 EST
This appears to be a dup of bug 541357 (or vice versa).
Comment 3 Milan Broz 2010-06-23 11:29:00 EDT

*** This bug has been marked as a duplicate of bug 541357 ***

Note You need to log in before you can comment on or make changes to this bug.