Bug 501735 - srpm doesn't require gcc-c++ or make
srpm doesn't require gcc-c++ or make
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 10:37 EDT by Máirín Duffy
Modified: 2009-05-20 11:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 11:27:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2009-05-20 10:37:41 EDT
Description of problem:

i'm building the latest srpm of inkscape for f10 so i can try it out on my laptop :)

however i noticed that it doesn't require gcc-c++ or make to build so it just failed until i figured i had to install those... it seems like the spec should require these...
Comment 1 Yanko Kaneti 2009-05-20 10:59:11 EDT
See https://fedoraproject.org/wiki/Packaging/Guidelines#Exceptions_2
gcc-c++ and make are part of the minimal build environment
you can get to there with  yum groupinstall buildsys-build
NOTABUG
Comment 2 Lubomir Rintel 2009-05-20 11:27:32 EDT
(In reply to comment #0)
> Description of problem:
> 
> i'm building the latest srpm of inkscape for f10 so i can try it out on my
> laptop :)

Still not using F11? :)

> however i noticed that it doesn't require gcc-c++ or make to build so it just
> failed until i figured i had to install those... it seems like the spec should
> require these...  

Nope, they're part of the build group. Preferred way to build packages on your machine is to use mock. Alternatively, you may want to install the build group so that you can sure there's nothing missing that's not BuildRequired. Here's how you list it:

$ koji list-groups dist-f10-build build 
build  [dist-f8-build]
  bash: None, default  [dist-fc6-build]
  bzip2: None, default  [dist-fc6-build]
  coreutils: None, default  [dist-fc6-build]
  cpio: None, default  [dist-fc6-build]
  diffutils: None, default  [dist-fc6-build]
  fedora-release: None, default  [dist-fc6-build]
  findutils: None, default  [dist-fc7-build]
  gawk: None, default  [dist-fc7-build]
  gcc: None, default  [dist-fc6-build]
  gcc-c++: None, default  [dist-fc6-build]
  grep: None, default  [dist-fc7-build]
  gzip: None, default  [dist-fc6-build]
  info: None, default  [dist-fc7-build]
  make: None, default  [dist-fc6-build]
  patch: None, default  [dist-fc6-build]
  redhat-rpm-config: None, default  [dist-fc6-build]
  rpm-build: None, default  [dist-fc6-build]
  sed: None, default  [dist-fc6-build]
  shadow-utils: None, default  [dist-f9-build]
  tar: None, default  [dist-fc6-build]
  unzip: None, default  [dist-fc6-build]
  util-linux-ng: None, default  [dist-f8-build]
  which: None, default  [dist-fc6-build]

Note You need to log in before you can comment on or make changes to this bug.