This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 501752 - Upgrade device-mapper to 1.02.32 version
Upgrade device-mapper to 1.02.32 version
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Milan Broz
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 11:36 EDT by Milan Broz
Modified: 2013-02-28 23:07 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2009-05-20 11:36:08 EDT
To fix reported bugs and add new features of lvm2, userspace device-mapper package will be updated to 1.02.32 version int RHEL5.4.

This change includes (beside bugs covered by other bugzillas):

Version 1.02.32 -
================================
  Fix segfault when using -U, -G and -M options in dmsetup.

Version 1.02.31 - 3rd March 2009
================================
  If kernel supports only one dm major number, use in place of any supplied.

Version 1.02.30 - 26th January 2009
====================================
  Add "all" field to reports expanding to all fields of report type.
  Enforce device name length and character limitations in libdm.
  Replace _dm_snprintf with EMIT_PARAMS macro for creating target lines.

Version 1.02.29 - 10th November 2008
====================================
  Merge device-mapper into the LVM2 tree.
  Split out dm-logging.h from log.h.
  Use lvm-types.h.
  Add usrsbindir to configure.

Because upstream source code is now merged with LVM2 tools, this bugzilla also covers all necessary changes to spec file.
(All fuctionality and binary package contents remains the same.)
Comment 1 Milan Broz 2009-05-21 03:41:15 EDT
changelog update:

Version 1.02.32 - 21st May 2009
===============================
  Only generate libdevmapper.a when configured to link statically.
  Export dm_tree_node_size_changed() from libdevmapper.
  Propagate the table size_changed property up the dm device tree.
  Detect failure to free memory pools when releasing the library.
  Fix segfault when getopt processes dmsetup -U, -G and -M options.


(in build device-mapper-1.02.32-1.el5)
Comment 3 Corey Marthaler 2009-07-28 15:36:43 EDT
Marking this bug verified.

device-mapper-1.02.32-1.el5 has passed all the lvm2/lvm2-cluster/device-mapper regression tests.
Comment 5 errata-xmlrpc 2009-09-02 07:56:13 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1392.html

Note You need to log in before you can comment on or make changes to this bug.