Bug 50176 - Filter out numlock only, rather than Mod2-Mod4, when grabbing keybindings
Filter out numlock only, rather than Mod2-Mod4, when grabbing keybindings
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-core (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Ben Levenson
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2001-07-27 13:51 EDT by Enrico Scholz
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-13 21:52:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/XF86Config-4 (2.30 KB, text/plain)
2001-07-30 18:07 EDT, Enrico Scholz
no flags Details
~/.Xmodmap (562 bytes, text/plain)
2001-07-30 18:09 EDT, Enrico Scholz
no flags Details

  None (edit)
Description Enrico Scholz 2001-07-27 13:51:55 EDT
Description of Problem:

I can neither set keybindings using the Meta-Key (Mod4) in the Panel/Global
Settings/Misc" dialog nor will such bindings (from older versions) be
recognized.

In other applications (XEmacs, xev) it works fine.


How Reproducible:

everytime


Steps to Reproduce:
1. right click on panel -> Panel -> Global Settings... -> Misc tab ->
Capture key...
2. press Meta-F2


Actual Results:

F2


Expected Results:

Mod4-F2


Additional Information:
	
gnome-core-1.4.0.4-16
gnome-libs-1.2.13-9
XFree86-4.1.0-0.8.6
$ cat ~/.Xmodmap
...
keycode 115  = Alt_L
keycode 64 = Meta_L

keycode 113 = Meta_R
keycode 116 = Super_R
keycode 117 = Alt_R Mode_switch

clear Mod1
clear Mod3
clear Mod4
clear Lock
clear control
add Lock = Caps_Lock
add control = Control_L Control_R
add Mod1 = Alt_L Alt_R
add Mod3 = Super_R
add Mod4 = Meta_L Meta_R
Comment 1 Jonathan Blandford 2001-07-30 17:26:18 EDT
I can't reproduce this.  Can you paste in what you get from xev?
Comment 2 Enrico Scholz 2001-07-30 18:06:28 EDT
When pressing & releasing the physical Alt key (mapped to Meta/Mod2; keys next
to ctrl are mapped to Alt/Mod1) I get with xev:

KeyPress event, serial 24, synthetic NO, window 0x5000002,
    root 0x3e, subw 0x0, time 98399912, (89,83), root:(774,701),
    state 0x0, keycode 64 (keysym 0xffe7, Meta_L), same_screen YES,
    XLookupString gives 0 characters:  ""

KeyRelease event, serial 29, synthetic NO, window 0x5000002,
    root 0x3e, subw 0x0, time 98400030, (89,83), root:(774,701),
    state 0x40, keycode 64 (keysym 0xffe7, Meta_L), same_screen YES,
    XLookupString gives 0 characters:  ""

kbd is configured in /etc/X11/XF86Config-4 as

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbLayout" "us"
        Option      "XkbModel" "microsoft"
EndSection


I have reproduced it on another machine (XFree86-4.1.0-0.9.4) without the
"XkbModel" also. I will attach the complete /etc/X11/XF86Config-4 file...
Comment 3 Enrico Scholz 2001-07-30 18:07:06 EDT
Created attachment 25471 [details]
/etc/X11/XF86Config-4
Comment 4 Enrico Scholz 2001-07-30 18:09:42 EDT
Created attachment 25472 [details]
~/.Xmodmap
Comment 5 Havoc Pennington 2002-03-04 16:10:27 EST
The panel deliberately filters Mod2-Mod4 to avoid getting numlock and that sort
of thing. It's possible to be smarter about filtering only whichever one is
numlock, 
scroll lock, and so on, but involves writing some more code.
Comment 6 Havoc Pennington 2002-07-02 17:39:28 EDT
Still present in Rawhide.
Comment 7 Havoc Pennington 2002-12-13 21:49:35 EST
This should be fixed in rawhide
Comment 8 Havoc Pennington 2002-12-13 21:51:21 EST
Trying to convince bugzilla that the estimate was 8 hours plus 8 hours were worked
Comment 9 Havoc Pennington 2002-12-13 21:52:37 EST
I officially don't understand the time tracking fields ;-)

Note You need to log in before you can comment on or make changes to this bug.