Bug 50182 - 7.1 rpm -bp crashes on XFree86-4.1.0-0.9.4 specfile
Summary: 7.1 rpm -bp crashes on XFree86-4.1.0-0.9.4 specfile
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 52022 57656 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-27 18:40 UTC by Havoc Pennington
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-27 18:40:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Havoc Pennington 2001-07-27 18:40:55 UTC
If I run rpm -bp SPECS/XFree86.spec on specfile from XFree86-4.1.0-0.9.4 
with rpm 4.0.2-8, then it segfaults. Maybe already fixed in beta rpm, 
don't know.

Comment 1 Jeff Johnson 2001-07-28 03:10:43 UTC
XFree86-4.1.0-0.9.4 is known to build with rpm-4.0.3.

Comment 2 Håvard Kvålen 2001-08-20 12:53:03 UTC
I see exactly this problem on a freshly installed RedHat 7.1 system.

Comment 3 Jeff Johnson 2001-08-20 13:33:54 UTC
Yup. Use of a parameterized macro in packaging XFree86 triggers
a segfault in rpm-4.0.2

Either
	a) upgrade to rpm-4.0.3 and use that for building XFree86
	b) look for an XFree86 package that doesn't use a parameterized macro

Comment 4 Mike A. Harris 2002-11-10 18:07:10 UTC
*** Bug 52022 has been marked as a duplicate of this bug. ***

Comment 5 Mike A. Harris 2002-11-10 18:11:00 UTC
*** Bug 57656 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.