Bug 501823 - route and ip show different routing tables for ipv6
route and ip show different routing tables for ipv6
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Thomas Graf
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 17:19 EDT by Richard Achmatowicz
Modified: 2014-06-18 04:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-26 06:28:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of differing route entries produced by route and ip (5.76 KB, text/plain)
2009-05-20 17:19 EDT, Richard Achmatowicz
no flags Details

  None (edit)
Description Richard Achmatowicz 2009-05-20 17:19:42 EDT
Created attachment 344879 [details]
Example of differing route entries produced by route and ip

Description of problem:

When viewing IPv6 routing tables using route and ip, different sets of routes are produced.  

Version-Release number of selected component (if applicable):

Linux jawa01.englab.brq.redhat.com 2.6.18-53.1.14.el5xen #1 SMP Tue Feb 19 07:33:17 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Always.

Steps to Reproduce:
1. install iproute2 package
2. display ipv6 routes using route
/sbin/route -A inet6
3. display ipv6 routes using ip
/sbin/ip -6 route show

Actual results:

The two sets of IPv6 routing entries are different  

Expected results:

The two sets of IPv6 routing entries should be the same.

Additional info:

I have attached some sample output from a RHEL 5 machine.
Comment 1 Thomas Graf 2009-08-24 08:06:56 EDT
As with IPv4, IPv6 routes belong to a specific routing table. ip -6 route show will only display the routes found in the "main" table.

See `ip -6 rule` for a list of IPv6 tables being lookup up. Then dispaly the contents of each table using the command `ip -6 route show table <name>`.

You may found the routes you are lacking in the `local` table.

Please note that `route' may not display all routes as it relies on the routes being exported via /proc which is not done for all routes.

Do you still see different sets of routes?
Comment 2 Thomas Graf 2010-03-30 07:54:47 EDT
Any news on this?
Comment 3 Thomas Graf 2010-08-26 06:28:19 EDT
Closed based on comment #1, please reopen if you think the problem is real.

Note You need to log in before you can comment on or make changes to this bug.