Bug 501842 - sosreport is missing batch mode
sosreport is missing batch mode
Status: CLOSED DUPLICATE of bug 500134
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Stokes
BaseOS QE
:
Depends On:
Blocks: 500134
  Show dependency treegraph
 
Reported: 2009-05-20 20:08 EDT by Alan Pevec
Modified: 2016-04-26 11:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Sos now includes a batch mode, in which it does not ask any questions during its run. Batch mode is invoked with the --batch option.
Story Points: ---
Clone Of: 500134
Environment:
Last Closed: 2009-06-24 10:15:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Pevec 2009-05-20 20:08:12 EDT
+++ This bug was initially created as a clone of Bug #500134 +++

Description of problem:
sos-1.7-9.16.el5_3.5 does not support --batch option found in sos-1.8-9.fc10.noarch:
  --batch               do not ask any question (batch mode)
This is need to produce non-interactive diagnostics reports by vdsm.
Possible workaround is to run: printf "\n\n\n" | sosreport
but it's cleaner to backport --batch option to RHEL5 sos.

Version-Release number of selected component (if applicable):
sos-1.7-9.16.el5_3.5

How reproducible:
always

Steps to Reproduce:
1. sosreport --batch
  
Actual results:
sosreport: error: no such option: --batch

Expected results:
sos report is generated

--- Additional comment from astokes@redhat.com on 2009-05-11 10:12:14 EDT ---

There is a --name, --ticket option in rhel5/4 sosreport. But I agree as I'd like to backport this batch option to this branch. Please duplicate for rhel5 as well

thanks,
adam
Comment 4 Adam Stokes 2009-06-24 10:15:00 EDT

*** This bug has been marked as a duplicate of bug 500134 ***
Comment 5 Ruediger Landmann 2009-09-02 01:12:18 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Sos now includes a batch mode, in which it does not ask any questions during its run. Batch mode is invoked with the --batch option.

Note You need to log in before you can comment on or make changes to this bug.