Bug 501862 - Installing Bootloader fails with LUKS disk
Installing Bootloader fails with LUKS disk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 02:17 EDT by Phip
Modified: 2009-05-21 11:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 11:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Abridged Anaconda Traceback (2.40 KB, text/plain)
2009-05-21 02:17 EDT, Phip
no flags Details

  None (edit)
Description Phip 2009-05-21 02:17:45 EDT
Created attachment 344913 [details]
Abridged Anaconda Traceback

Description of problem:
Installing FC11-pre i386 DVD, an Exception dialog appears in the "Installing Bootloader" phase.

Version-Release number of selected component (if applicable):
 11.5.0.47

How reproducible:
Same result in two tries.

Additional info:

My system has a single drive, with three partitions, as set up by fedora 10 installer:
sda1  / (ext3)
sda2  -swap-
sda3  /home (ext3, LUKS encrypted)

When I ran the installer, I instructed it to format sda1 and sda2 and keep sda3 as /home.

I tried booting into rescue mode and running grub-install, but it says:
"/dev/mapper/luks-c8474611-b9f2-4dbc-93de-de22c5baad05 does not have any corresponding BIOS drive."

The attached traceback is transcribed in abridged form because I was unable to save or send it. When clicking the save button, Anaconda stalls at the searching for drives screen and does not recover. Hopefully I've included enough information to get started, at least.
Comment 1 Chris Lumens 2009-05-21 10:26:47 EDT
The version you're testing is pretty old now.  Can you give a later test release a try and see if you're still experiencing this problem?
Comment 2 Phip 2009-05-21 11:18:09 EDT
I ran the live cd and updated anaconda to 11.5.0.54-1, and was able to complete an installation.
Comment 3 Chris Lumens 2009-05-21 11:39:15 EDT
Great, thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.