Bug 501864 - Playing a video on youtube and switching back from full to windowed screen crashes firefox.
Playing a video on youtube and switching back from full to windowed screen cr...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 03:06 EDT by Eddie Lania
Modified: 2009-08-24 17:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 17:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gdb backtrace and other info. (22.86 KB, text/plain)
2009-05-21 11:08 EDT, Eddie Lania
no flags Details

  None (edit)
Description Eddie Lania 2009-05-21 03:06:49 EDT
Description of problem: Playing a video on youtube and switching back from full to windowed screen crashes firefox.


Version-Release number of selected component (if applicable):
firefox-3.5-0.20.beta4.fc11.i586
flash-plugin-10.0.22.87-release.i386


How reproducible: Allways.


Steps to Reproduce:
1. Open a video on youtube and when it is playing switch to fullscreen.
2. Hit the escape key to switch back to windowed video screen.
3.
  
Actual results: Firefox exits/crashes when escape is pressed.


Expected results: Return to normal window.


Additional info:
Comment 1 Matěj Cepl 2009-05-21 08:56:59 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Eddie Lania 2009-05-21 11:08:16 EDT
Created attachment 344981 [details]
Gdb backtrace and other info.

rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*
gstreamer-plugins-good-0.10.14-2.fc11.i586
firefox-debuginfo-3.5-0.20.beta4.fc11.i586
audacious-plugins-freeworld-1.5.1-2.fc11.i586
alsa-plugins-upmix-1.0.18-3.fc11.i586
thunar-media-tags-plugin-0.1.2-6.fc11.i586
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.i586
PackageKit-yum-plugin-0.4.6-8.fc11.i586
firefox-3.5-0.20.beta4.fc11.i586
vamp-plugin-sdk-2.0-5.fc11.i586
audacious-plugins-freeworld-alac-1.5.1-2.fc11.i586
flash-plugin-10.0.22.87-release.i386
gstreamer-plugins-base-devel-0.10.22-2.fc11.i586
yum-plugin-fastestmirror-1.1.21-2.fc11.noarch
audacious-plugins-1.5.1-4.fc11.i586
plymouth-plugin-label-0.7.0-0.2009.05.15.1.fc11.i586
audacious-plugins-freeworld-wma-1.5.1-2.fc11.i586
audacious-plugins-freeworld-tta-1.5.1-2.fc11.i586
plymouth-plugin-throbgress-0.7.0-0.2009.05.15.1.fc11.i586
audacious-plugins-freeworld-mp3-1.5.1-2.fc11.i586
yum-plugin-changelog-1.1.21-2.fc11.noarch
gstreamer-plugins-good-devel-0.10.14-2.fc11.i586
gstreamer-plugins-bad-extras-0.10.11-4.fc11.i586
amsn-plugins-0.97.2-4.fc11.i586
djvulibre-mozplugin-3.5.21-2.fc11.i586
yum-plugin-priorities-1.1.21-2.fc11.noarch
plymouth-plugin-two-step-0.7.0-0.2009.05.15.1.fc11.i586
audacious-plugins-freeworld-aac-1.5.1-2.fc11.i586
mozilla-filesystem-1.9-4.fc11.i586
xulrunner-debuginfo-1.9.1-0.20.beta4.fc11.i586
gstreamer-plugins-ugly-0.10.11-1.fc11.i586
alsa-plugins-pulseaudio-1.0.18-3.fc11.i586
setroubleshoot-plugins-2.0.16-1.fc11.noarch
xulrunner-1.9.1-0.20.beta4.fc11.i586
gstreamer-plugins-bad-0.10.11-4.fc11.i586
gstreamer-plugins-base-0.10.22-2.fc11.i586
audacious-plugins-freeworld-mms-1.5.1-2.fc11.i586
anaconda-yum-plugins-1.0-4.fc11.noarch
totem-mozplugin-2.26.2-1.fc11.i586
gstreamer-plugins-farsight-0.12.10-2.fc11.i586
plymouth-plugin-space-flares-0.7.0-0.2009.05.15.1.fc11.i586
gstreamer-plugins-bad-devel-0.10.11-4.fc11.i586
Comment 3 Matěj Cepl 2009-05-27 17:14:02 EDT
I am sorry, but this is crash in libflashplayer.so ... we cannot do much about it.

Closing as CANTFIX (because we cannot)
Comment 4 Martin Stransky 2009-05-28 03:10:13 EDT
Note: Try to install nspluginwrapper package, it shields a browser from flash plug-in crashes.
Comment 5 Karl Tomlinson 2009-08-24 17:13:28 EDT
Will be fixed in Firefox 3.5.3:
https://bugzilla.mozilla.org/show_bug.cgi?id=493541

Note You need to log in before you can comment on or make changes to this bug.